summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-03-28 14:38:59 -0400
committerMike Frysinger <vapier@gentoo.org>2016-03-28 15:10:57 -0400
commit189309b1697e8cd8dcb88e8a617734fbb545cec4 (patch)
treea1665cab239f581ec8feff8793b8bca1f97301af /dev-python/gcs-oauth2-boto-plugin
parentdev-python/gcs-oauth2-boto-plugin: drop old <1.8-r1 versions (diff)
downloadgentoo-189309b1697e8cd8dcb88e8a617734fbb545cec4.tar.gz
gentoo-189309b1697e8cd8dcb88e8a617734fbb545cec4.tar.bz2
gentoo-189309b1697e8cd8dcb88e8a617734fbb545cec4.zip
dev-python/gcs-oauth2-boto-plugin: version bump to 1.12
Diffstat (limited to 'dev-python/gcs-oauth2-boto-plugin')
-rw-r--r--dev-python/gcs-oauth2-boto-plugin/Manifest1
-rw-r--r--dev-python/gcs-oauth2-boto-plugin/files/gcs-oauth2-boto-plugin-1.12-use-friendy-version-checks.patch16
-rw-r--r--dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.12.ebuild34
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/gcs-oauth2-boto-plugin/Manifest b/dev-python/gcs-oauth2-boto-plugin/Manifest
index a68ac5bf4642..200d8f1f827c 100644
--- a/dev-python/gcs-oauth2-boto-plugin/Manifest
+++ b/dev-python/gcs-oauth2-boto-plugin/Manifest
@@ -1,2 +1,3 @@
+DIST gcs-oauth2-boto-plugin-1.12.tar.gz 14601 SHA256 4d35958f3724d6632f91a70acb3761c3860425ea6438c001e7e6b94d1431ad23 SHA512 998bc3187ef1483d8301f952dd68daf1dabf5775c7c948a18bdec1ed1c0ecacc336d8a0b4401e93f10e7d2b70a2fd4675c2c9d8f077fed5f126ee334e966ca19 WHIRLPOOL 48bda2622963b93b3d87abd2c3744ca9a21ba1e9f574b0a29c02e1de7379f4f4af35612b89cfcce60e09ee629960f2491347b11f7cfe26b6ae4d5199c2783af1
DIST gcs-oauth2-boto-plugin-1.8.tar.gz 13248 SHA256 cb4f3c608c953c9f6eecbad0dd33c6a2dba283cf1cd332ceaac1a9ba8a17c64b SHA512 5504fc38d58ee68a78ee2b8e6c3757045494d000748382bc26888a65085cec08d2d137c63cb51afd1cef72d31b3f0cac5d40014548cca47c5322a67a7f1ef204 WHIRLPOOL 238ee67cdad11162abe614fad7d6eb6175a27fc132c790e17f4380373b8c8d48906e5ac361c4d3c34fbac85e851bdf6426c3660434bf809d4abca87f6cb995a9
DIST gcs-oauth2-boto-plugin-1.9.tar.gz 14625 SHA256 82e70621354a0291ff312d060fedf25f8016eb0af215d443562ac2b26f94b28d SHA512 439def0c7b78a103bd3041600e25eaede44c3aac8a161f12acd6dee98cd8404b03229df24cf4e7814d63600ca50793496a80893f1e32f8ed8ac4a2825dd07df8 WHIRLPOOL ba28ac45e909a2410f36c81ba7f5e83e9c71963b1fd4d69df7fe425d26f066ea8376cf935f6b732c57d98b7d2e770d68a2658953279f0985725970af9d206dd6
diff --git a/dev-python/gcs-oauth2-boto-plugin/files/gcs-oauth2-boto-plugin-1.12-use-friendy-version-checks.patch b/dev-python/gcs-oauth2-boto-plugin/files/gcs-oauth2-boto-plugin-1.12-use-friendy-version-checks.patch
new file mode 100644
index 000000000000..73f895168e8f
--- /dev/null
+++ b/dev-python/gcs-oauth2-boto-plugin/files/gcs-oauth2-boto-plugin-1.12-use-friendy-version-checks.patch
@@ -0,0 +1,16 @@
+--- a/setup.py
++++ b/setup.py
+@@ -36,11 +36,9 @@
+ requires = [
+ 'boto>=2.29.1',
+ 'httplib2>=0.8',
+- 'oauth2client==1.5.2',
++ 'oauth2client>=1.5.2',
+ 'pyOpenSSL>=0.13',
+- # Not using 1.02 because of:
+- # https://code.google.com/p/socksipy-branch/issues/detail?id=3
+- 'SocksiPy-branch==1.01',
++ 'SocksiPy-branch>=1.01',
+ 'retry_decorator>=1.0.0',
+ ]
+
diff --git a/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.12.ebuild b/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.12.ebuild
new file mode 100644
index 000000000000..5793adac44bc
--- /dev/null
+++ b/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-1.12.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+# Python 3: https://github.com/GoogleCloudPlatform/gcs-oauth2-boto-plugin/issues/10
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="OAuth 2.0 plugin for Google Cloud Storage credentials in the Boto library"
+HOMEPAGE="https://pypi.python.org/pypi/gcs-oauth2-boto-plugin"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.12-use-friendy-version-checks.patch"
+)
+
+# Keep versions in sync with setup.py.
+DEPEND="${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${PYTHON_DEPS}
+ >=dev-python/boto-2.29.1[${PYTHON_USEDEP}]
+ >=dev-python/httplib2-0.8[${PYTHON_USEDEP}]
+ >=dev-python/oauth2client-1.5.2[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
+ >=dev-python/retry-decorator-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/PySocks-1.01[${PYTHON_USEDEP}]"