summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2018-06-15 14:15:48 -0700
committerZac Medico <zmedico@gentoo.org>2018-06-15 14:25:26 -0700
commitebcd34b5e2b8eb2983c12139d5c60783b7a73cea (patch)
tree755177905136d8cb1af7e1ec78f761f050b8f561 /dev-python/gcs-oauth2-boto-plugin
parentdev-python/httplib2: version bump to 0.11.3 (diff)
downloadgentoo-ebcd34b5e2b8eb2983c12139d5c60783b7a73cea.tar.gz
gentoo-ebcd34b5e2b8eb2983c12139d5c60783b7a73cea.tar.bz2
gentoo-ebcd34b5e2b8eb2983c12139d5c60783b7a73cea.zip
dev-python/gcs-oauth2-boto-plugin: version bump to 2.1
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/gcs-oauth2-boto-plugin')
-rw-r--r--dev-python/gcs-oauth2-boto-plugin/Manifest1
-rw-r--r--dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-2.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/gcs-oauth2-boto-plugin/Manifest b/dev-python/gcs-oauth2-boto-plugin/Manifest
index 816aad945556..96fafcbfed51 100644
--- a/dev-python/gcs-oauth2-boto-plugin/Manifest
+++ b/dev-python/gcs-oauth2-boto-plugin/Manifest
@@ -1,2 +1,3 @@
DIST gcs-oauth2-boto-plugin-1.14.tar.gz 14980 BLAKE2B 1123633b419291433d7cfa9a284303a7ae2a6b407f487b45897df6945a63f6b0cce733a5940e74acb70bcd9740a7c0cbd3828abfb4163f7ab845a9ff2c652a1b SHA512 86804a599c969c63587387df21a2396a27509981cc13a3f92bc98a645757362e77c63b68956ebd2663a721bb51993c9e61679db85a67de48d017ddad7de044b7
DIST gcs-oauth2-boto-plugin-1.8.tar.gz 13248 BLAKE2B 831a1b88035d6331ac2cb122fda5ffabd6319b7a030ae8c46dac32be571bdff034d6e60830e5e4403b65a414487c874cd4743f537a9c1d3674bcb1461e457945 SHA512 5504fc38d58ee68a78ee2b8e6c3757045494d000748382bc26888a65085cec08d2d137c63cb51afd1cef72d31b3f0cac5d40014548cca47c5322a67a7f1ef204
+DIST gcs-oauth2-boto-plugin-2.1.tar.gz 15789 BLAKE2B f98eb41d07aede9379bb256723c217be1c2fcf2cda18e555a5d7e85bb402215052ff4d7770cdb4066fd989f7e78d070ea19e1a469f5e6dec2b94a367a6dc3c19 SHA512 26b519fa2987e83a687907aa72e0c9eb8b2a2c48143bc1bf13bad79791379daaae190a23f9f35d1a570e21c6800d5860bbb94f3c3f3b2ff7bfcfec8a5a39af7c
diff --git a/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-2.1.ebuild b/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-2.1.ebuild
new file mode 100644
index 000000000000..96d2afafe5ac
--- /dev/null
+++ b/dev-python/gcs-oauth2-boto-plugin/gcs-oauth2-boto-plugin-2.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="OAuth 2.0 plugin for Google Cloud Storage credentials in the Boto library"
+HOMEPAGE="https://pypi.org/project/gcs-oauth2-boto-plugin/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.13-use-friendy-version-checks.patch"
+)
+
+# Keep versions in sync with setup.py.
+DEPEND="${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ )"
+RDEPEND="${PYTHON_DEPS}
+ >=dev-python/boto-2.29.1[${PYTHON_USEDEP}]
+ >=dev-python/httplib2-0.8[${PYTHON_USEDEP}]
+ >=dev-python/oauth2client-1.5.2[${PYTHON_USEDEP}]
+ !=dev-python/oauth2client-2.0*
+ >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
+ >=dev-python/retry-decorator-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/PySocks-1.01[${PYTHON_USEDEP}]
+ >=dev-python/six-1.6.1[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -i \
+ -e '/SocksiPy-branch/d' \
+ setup.py || die
+ # Make sure the unittests aren't installed.
+ mv gcs_oauth2_boto_plugin/test_oauth2_client.py ./ || die
+}
+
+python_test() {
+ ${EPYTHON} "${S}"/test_oauth2_client.py || die
+}