summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-04 14:12:24 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-04 15:15:15 +0100
commitdcee984324128526b8fd33c3fe7d5616ef521adc (patch)
tree2115dc51554e9bb2cd6072b39953976e31aea541 /dev-python/genty/genty-1.2.1.ebuild
parentmedia-libs/qt-gstreamer: restore dropped keywords (diff)
downloadgentoo-dcee984324128526b8fd33c3fe7d5616ef521adc.tar.gz
gentoo-dcee984324128526b8fd33c3fe7d5616ef521adc.tar.bz2
gentoo-dcee984324128526b8fd33c3fe7d5616ef521adc.zip
dev-python/genty: New package, ebuild written by me
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/genty/genty-1.2.1.ebuild')
-rw-r--r--dev-python/genty/genty-1.2.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/genty/genty-1.2.1.ebuild b/dev-python/genty/genty-1.2.1.ebuild
new file mode 100644
index 000000000000..f0fef86a6fbd
--- /dev/null
+++ b/dev-python/genty/genty-1.2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Allows you to run a test with multiple data sets"
+HOMEPAGE="https://pypi.python.org/pypi/genty https://github.com/box/genty"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# https://github.com/box/genty/issues/42
+RESTRICT=test
+
+python_test() {
+ esetup.py test --verbose
+}