summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-20 17:20:25 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-20 17:37:42 +0200
commitd044346d47fdbf8d2871cb4e1962f0dd741412c1 (patch)
treef08cc227fd36f0cc5c1004d4325211ba14d3a37f /dev-python/genty/genty-1.3.2-r1.ebuild
parentdev-python/flaky: Remove python2 (diff)
downloadgentoo-d044346d47fdbf8d2871cb4e1962f0dd741412c1.tar.gz
gentoo-d044346d47fdbf8d2871cb4e1962f0dd741412c1.tar.bz2
gentoo-d044346d47fdbf8d2871cb4e1962f0dd741412c1.zip
dev-python/genty: Remove python2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/genty/genty-1.3.2-r1.ebuild')
-rw-r--r--dev-python/genty/genty-1.3.2-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/genty/genty-1.3.2-r1.ebuild b/dev-python/genty/genty-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..fb5597c17e31
--- /dev/null
+++ b/dev-python/genty/genty-1.3.2-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Allows you to run a test with multiple data sets"
+HOMEPAGE="https://pypi.org/project/genty/ https://github.com/box/genty"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests setup.py