summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-28 04:48:50 +0000
committerSam James <sam@gentoo.org>2021-12-28 04:50:56 +0000
commit56ce1e6d788afb6177f722eede892330b3e00dcc (patch)
tree5b8a65fcb6bffb200afcb0286f152dbae89ce438 /dev-python/gevent/gevent-21.12.0.ebuild
parentmedia-libs/codec2: add 1.0.3 (diff)
downloadgentoo-56ce1e6d788afb6177f722eede892330b3e00dcc.tar.gz
gentoo-56ce1e6d788afb6177f722eede892330b3e00dcc.tar.bz2
gentoo-56ce1e6d788afb6177f722eede892330b3e00dcc.zip
dev-python/gevent: add 21.12.0
- Re-enabled some hanging/failing tests - Add dnspython tests again - Excluded more network-related tests - Avoid deprecated method for disabling "embedded" libs (bundled) Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/gevent/gevent-21.12.0.ebuild')
-rw-r--r--dev-python/gevent/gevent-21.12.0.ebuild100
1 files changed, 100 insertions, 0 deletions
diff --git a/dev-python/gevent/gevent-21.12.0.ebuild b/dev-python/gevent/gevent-21.12.0.ebuild
new file mode 100644
index 000000000000..0c7cee33a7e9
--- /dev/null
+++ b/dev-python/gevent/gevent-21.12.0.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+PYTHON_REQ_USE="ssl(+),threads(+)"
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Coroutine-based network library"
+HOMEPAGE="https://www.gevent.org/ https://pypi.org/project/gevent/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-libs/libev-4.31:=
+ dev-libs/libuv:=
+ >=net-dns/c-ares-1.12:=
+"
+RDEPEND="${DEPEND}
+ virtual/python-greenlet[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx doc
+
+# Tests take long and fail terribly a few times.
+# It also seems that they require network access.
+#RESTRICT="test"
+
+python_prepare_all() {
+ export GEVENTSETUP_EMBED="false"
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ append-flags -fno-strict-aliasing
+}
+
+python_test() {
+ # Just in case.
+ export GEVENTTEST_USE_RESOURCES=-network
+
+ cd src/gevent/tests || die
+
+ # Tests which need network but aren't marked as such
+ echo "test__getaddrinfo_import.py" >> tests_that_dont_use_resolver.txt || die
+ echo "test_socketqcqqrwns.py" >> tests_that_dont_use_resolver.txt || die
+
+ # Test hangs (testPeek)
+ echo "test_socket.py" >> tests_that_dont_use_resolver.txt || die
+
+ # TODO: figure out how to make them work and not hang
+ #GEVENT_RESOLVER=ares \
+ # "${EPYTHON}" -m gevent.tests \
+ # --verbose \
+ # -uall,-network \
+ # --config known_failures.py \
+ # --ignore tests_that_dont_use_resolver.txt || die
+ GEVENT_RESOLVER=dnspython \
+ "${EPYTHON}" -m gevent.tests \
+ --verbose \
+ -uall,-network \
+ --config known_failures.py \
+ --ignore tests_that_dont_use_resolver.txt || die
+ GEVENT_RESOLVER=thread \
+ "${EPYTHON}" -m gevent.tests \
+ --verbose \
+ -uall,-network \
+ --config known_failures.py \
+ --ignore tests_that_dont_use_resolver.txt || die
+ GEVENT_FILE=thread \
+ "${EPYTHON}" -m gevent.tests \
+ --verbose \
+ -uall,-network \
+ --config known_failures.py \
+ test__*subprocess*.py || die
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS README.rst )
+ use examples && dodoc -r examples
+
+ distutils-r1_python_install_all
+}