summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-10-24 11:13:14 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-10-24 11:20:15 +0200
commit6c76f6521560c1b8f14eb034b2f4e3ab9611ff6b (patch)
treeffacc15d641df4bfac728ea1cdd9530ebb97eec4 /dev-python/geventhttpclient/geventhttpclient-1.3.1-r1.ebuild
parentmedia-libs/glyr: Drop old (diff)
downloadgentoo-6c76f6521560c1b8f14eb034b2f4e3ab9611ff6b.tar.gz
gentoo-6c76f6521560c1b8f14eb034b2f4e3ab9611ff6b.tar.bz2
gentoo-6c76f6521560c1b8f14eb034b2f4e3ab9611ff6b.zip
dev-python/geventhttpclient: fix ImportError while collecting tests
Closes: https://bugs.gentoo.org/667758 Signed-off-by: Louis Sautier <sbraz@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-python/geventhttpclient/geventhttpclient-1.3.1-r1.ebuild')
-rw-r--r--dev-python/geventhttpclient/geventhttpclient-1.3.1-r1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/geventhttpclient/geventhttpclient-1.3.1-r1.ebuild b/dev-python/geventhttpclient/geventhttpclient-1.3.1-r1.ebuild
index bbedb9e89a28..a16291b3b011 100644
--- a/dev-python/geventhttpclient/geventhttpclient-1.3.1-r1.ebuild
+++ b/dev-python/geventhttpclient/geventhttpclient-1.3.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -36,7 +36,9 @@ python_prepare_all() {
python_test() {
# Ignore tests which require network access
- py.test src/geventhttpclient/tests --ignore \
+ # Append to sys.path to avoid ImportError
+ # https://bugs.gentoo.org/667758
+ pytest --import-mode=append -vv src/geventhttpclient/tests --ignore \
src/geventhttpclient/tests/test_client.py || \
die "Tests failed with ${EPYTHON}"
}