summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-07 13:19:59 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-07 13:39:03 +0100
commit15012a3c339c0b0fcaea66e98ed80d95daec3131 (patch)
tree6fbd74ebef66549e0649e76497c4cfe60f7aad85 /dev-python/geventhttpclient
parentdev-libs/volume_key: Removed old (diff)
downloadgentoo-15012a3c339c0b0fcaea66e98ed80d95daec3131.tar.gz
gentoo-15012a3c339c0b0fcaea66e98ed80d95daec3131.tar.bz2
gentoo-15012a3c339c0b0fcaea66e98ed80d95daec3131.zip
dev-python/geventhttpclient: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/geventhttpclient')
-rw-r--r--dev-python/geventhttpclient/Manifest1
-rw-r--r--dev-python/geventhttpclient/geventhttpclient-1.4.4-r1.ebuild50
2 files changed, 0 insertions, 51 deletions
diff --git a/dev-python/geventhttpclient/Manifest b/dev-python/geventhttpclient/Manifest
index f79e41f622b7..ac58fe5b04b5 100644
--- a/dev-python/geventhttpclient/Manifest
+++ b/dev-python/geventhttpclient/Manifest
@@ -1,2 +1 @@
-DIST geventhttpclient-1.4.4.tar.gz 57620 BLAKE2B 20b60cfa7e8221b050bfd95a6e23c2f3eee87c0df1e93171719c7ba1804e88c918471cdd01cf4c6020fb6d44d0a1b911ee09dd44cc1e150b5d18d6052f2904cf SHA512 c6a8580707f3178a3a55eb638b9e3f36f82aecbd8a5ce044f0b8c167d88ad2bec584275bed6b720a5f7a546b0ffd113bec28dd2e1ff4290c60f0b5e13542b737
DIST geventhttpclient-1.4.5.tar.gz 58183 BLAKE2B 48d44048e7040552824ed19ac49c6dda41536ffded56bae0d942c06f111a327a1d571872f35f388853b479ea1aaa6de518f86e7ee72e362360492530ade65131 SHA512 9ffe00c79b145dab104e1dce336e072060f315d9bee880daf64b5f1f52e661d810dab9a60286320a7d30cf0e794465f201c039cc31fe7ec325cdb3a8350c9f7d
diff --git a/dev-python/geventhttpclient/geventhttpclient-1.4.4-r1.ebuild b/dev-python/geventhttpclient/geventhttpclient-1.4.4-r1.ebuild
deleted file mode 100644
index 5a2873ff93cb..000000000000
--- a/dev-python/geventhttpclient/geventhttpclient-1.4.4-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8,9} )
-
-inherit distutils-r1
-
-DESCRIPTION="A high performance, concurrent HTTP client library for Python using gevent"
-HOMEPAGE="https://github.com/gwik/geventhttpclient"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/certifi[${PYTHON_USEDEP}]
- dev-python/gevent[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- ${RDEPEND}
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-python_prepare_all() {
- # Skip SNI tests which require dpkt
- sed -i '/^import dpkt.ssl/d' src/geventhttpclient/tests/test_ssl.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local skipped_tests=(
- # Require dpkt
- src/geventhttpclient/tests/test_ssl.py::test_implicit_sni_from_host_in_ssl
- src/geventhttpclient/tests/test_ssl.py::test_implicit_sni_from_header_in_ssl
- src/geventhttpclient/tests/test_ssl.py::test_explicit_sni_in_ssl
- )
- # Append to sys.path to avoid ImportError
- # https://bugs.gentoo.org/667758
- # Skip tests which require internet access
- pytest --import-mode=append -vv ${skipped_tests[@]/#/--deselect } \
- -m "not online" || die "Tests failed with ${EPYTHON}"
-}