summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-29 13:19:47 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-29 13:25:52 +0300
commit4754810e2c8111cda1253a2b68f34eb13d5457e6 (patch)
treee0c9ef615432fabeacc84c0115a0186ed385b32f /dev-python/geventhttpclient
parentdev-lang/smlnj: bump to 110.99.3 (diff)
downloadgentoo-4754810e2c8111cda1253a2b68f34eb13d5457e6.tar.gz
gentoo-4754810e2c8111cda1253a2b68f34eb13d5457e6.tar.bz2
gentoo-4754810e2c8111cda1253a2b68f34eb13d5457e6.zip
dev-python/geventhttpclient: add 2.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/geventhttpclient')
-rw-r--r--dev-python/geventhttpclient/Manifest1
-rw-r--r--dev-python/geventhttpclient/geventhttpclient-2.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/geventhttpclient/Manifest b/dev-python/geventhttpclient/Manifest
index 0697e6a0ca7c..9b9982cfb17c 100644
--- a/dev-python/geventhttpclient/Manifest
+++ b/dev-python/geventhttpclient/Manifest
@@ -1 +1,2 @@
DIST geventhttpclient-1.5.5.tar.gz 59566 BLAKE2B f43ffe9880eefe77f19adc00bcef612df057f96e256f50ca4081658d7e0d01deca2473da3d2055dbc1cb98fc4f7f0a7442809fdcab635c43042792e2601efdb9 SHA512 89efe008099935ac8715ddf09c13e70c1a3552da50c495522b2a62e1ff51a407808e6b797f8fd3b0863a3a59e5b03e604bda8b1027c0326da75cb1fddb5d0fa3
+DIST geventhttpclient-2.0.tar.gz 73677 BLAKE2B b466f7153e646b3d9af0b301789aaa92df28dad505c375ec7fdcfb8d888d8942edba3f4c776ef4fc252756fb2a37bbee7d61c4a1e912c8c7d716a57fd49fee0e SHA512 1f53cf8636e6baba4cb0d8d7b233f903efec2d74413cfb2d768bff94f3a9b91ae59444981a1399b010e73120c390b52b1449424571c7ee9bdad818e5ce72ae8c
diff --git a/dev-python/geventhttpclient/geventhttpclient-2.0.ebuild b/dev-python/geventhttpclient/geventhttpclient-2.0.ebuild
new file mode 100644
index 000000000000..5850080039c3
--- /dev/null
+++ b/dev-python/geventhttpclient/geventhttpclient-2.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A high performance, concurrent HTTP client library for Python using gevent"
+HOMEPAGE="
+ https://github.com/geventhttpclient/geventhttpclient/
+ https://pypi.org/project/geventhttpclient/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/gevent[events(+),${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Avoid ModuleNotFoundError for tests we skip later
+ sed -e '/^import dpkt.ssl/d' -i src/geventhttpclient/tests/test_ssl.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # These SNI tests require dpkt which is not in the tree
+ src/geventhttpclient/tests/test_ssl.py::test_implicit_sni_from_host_in_ssl
+ src/geventhttpclient/tests/test_ssl.py::test_implicit_sni_from_header_in_ssl
+ src/geventhttpclient/tests/test_ssl.py::test_explicit_sni_in_ssl
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # Skip tests which require internet access
+ epytest -m "not online"
+}