summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-25 13:03:12 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-25 13:03:12 +0100
commitbfc59c17703d147b2f44c6bd781eb7149bcc1e39 (patch)
tree92b63030463478e0421e2307c57bfaccc09e5616 /dev-python/geventhttpclient
parentdev-python/geventhttpclient: Stabilize 1.3.1-r1 ALLARCHES (diff)
downloadgentoo-bfc59c17703d147b2f44c6bd781eb7149bcc1e39.tar.gz
gentoo-bfc59c17703d147b2f44c6bd781eb7149bcc1e39.tar.bz2
gentoo-bfc59c17703d147b2f44c6bd781eb7149bcc1e39.zip
dev-python/geventhttpclient: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/geventhttpclient')
-rw-r--r--dev-python/geventhttpclient/geventhttpclient-1.3.1.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/geventhttpclient/geventhttpclient-1.3.1.ebuild b/dev-python/geventhttpclient/geventhttpclient-1.3.1.ebuild
deleted file mode 100644
index eaac2cb385a9..000000000000
--- a/dev-python/geventhttpclient/geventhttpclient-1.3.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_6} )
-
-inherit distutils-r1
-
-DESCRIPTION="A high performance, concurrent HTTP client library for Python using gevent"
-HOMEPAGE="https://github.com/gwik/geventhttpclient"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/certifi[${PYTHON_USEDEP}]
- dev-python/gevent[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-python_prepare_all() {
- # https://github.com/gwik/geventhttpclient/pull/82
- rm -rf src/geventhttpclient/tests/__pycache__ || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # Ignore tests which require network access
- py.test src/geventhttpclient/tests --ignore \
- src/geventhttpclient/tests/test_client.py || \
- die "Tests failed with ${EPYTHON}"
-}