summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-15 08:51:35 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-15 10:04:01 +0200
commitc21aa3df223062425a9fda05de58de655677db13 (patch)
treeff8fdace0c576a41467145cd6e404132dc17a4a8 /dev-python/geventhttpclient
parentdev-python/python-debian: Bump to 0.1.48 (diff)
downloadgentoo-c21aa3df223062425a9fda05de58de655677db13.tar.gz
gentoo-c21aa3df223062425a9fda05de58de655677db13.tar.bz2
gentoo-c21aa3df223062425a9fda05de58de655677db13.zip
dev-python/geventhttpclient: Bump to 2.0.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/geventhttpclient')
-rw-r--r--dev-python/geventhttpclient/Manifest1
-rw-r--r--dev-python/geventhttpclient/geventhttpclient-2.0.7.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/geventhttpclient/Manifest b/dev-python/geventhttpclient/Manifest
index 95269ee86af4..8d2913b4593c 100644
--- a/dev-python/geventhttpclient/Manifest
+++ b/dev-python/geventhttpclient/Manifest
@@ -1 +1,2 @@
DIST geventhttpclient-2.0.2.tar.gz 73821 BLAKE2B 6e12c0a7eabf2d15540192e161f27e4ef5aa771ac8b60deb00c0dbfd804e5d81f729609649c88b9b8cd51125b06afaf3d31367896ada339731ba3606ef64edda SHA512 d22453bc4fef8d9ad3b98a137d74df1647c69c594a8fa4b49848e71ca472373e44c70e3ed3798d73aca9089495cff1b5f888d1b1e39b1da60ee9052935b7b0a1
+DIST geventhttpclient-2.0.7.tar.gz 75969 BLAKE2B f749e42ccfd981cc67c1692695454f410708ca75f24b2ae6408556bda07d1e45f367421fbddc203f46ac82daf539d192fdab16245a20b6f3f883478c8b8e354f SHA512 7570b297c13a28761ec639721ecb44fdcac46141167e67ceac4e632058458b62acef0513c794c80e44980747807a175e7a39e6c5ff272be3ceddbeca9f629114
diff --git a/dev-python/geventhttpclient/geventhttpclient-2.0.7.ebuild b/dev-python/geventhttpclient/geventhttpclient-2.0.7.ebuild
new file mode 100644
index 000000000000..5850080039c3
--- /dev/null
+++ b/dev-python/geventhttpclient/geventhttpclient-2.0.7.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A high performance, concurrent HTTP client library for Python using gevent"
+HOMEPAGE="
+ https://github.com/geventhttpclient/geventhttpclient/
+ https://pypi.org/project/geventhttpclient/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/gevent[events(+),${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Avoid ModuleNotFoundError for tests we skip later
+ sed -e '/^import dpkt.ssl/d' -i src/geventhttpclient/tests/test_ssl.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # These SNI tests require dpkt which is not in the tree
+ src/geventhttpclient/tests/test_ssl.py::test_implicit_sni_from_host_in_ssl
+ src/geventhttpclient/tests/test_ssl.py::test_implicit_sni_from_header_in_ssl
+ src/geventhttpclient/tests/test_ssl.py::test_explicit_sni_in_ssl
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # Skip tests which require internet access
+ epytest -m "not online"
+}