summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-10-12 00:09:53 +0200
committerLouis Sautier <sbraz@gentoo.org>2021-10-12 00:10:08 +0200
commitda768ed30ccec381425fd9736d78f65a8ce1a3ef (patch)
tree6ae34a6aadfd211d9cf74a5e0c7a84ac6ee62e74 /dev-python/geventhttpclient
parentdev-python/geventhttpclient: add 1.5.3 (diff)
downloadgentoo-da768ed30ccec381425fd9736d78f65a8ce1a3ef.tar.gz
gentoo-da768ed30ccec381425fd9736d78f65a8ce1a3ef.tar.bz2
gentoo-da768ed30ccec381425fd9736d78f65a8ce1a3ef.zip
dev-python/geventhttpclient: drop 1.5.1
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/geventhttpclient')
-rw-r--r--dev-python/geventhttpclient/Manifest1
-rw-r--r--dev-python/geventhttpclient/geventhttpclient-1.5.1.ebuild49
2 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/geventhttpclient/Manifest b/dev-python/geventhttpclient/Manifest
index c62ee31cd7f5..edac954e8ab9 100644
--- a/dev-python/geventhttpclient/Manifest
+++ b/dev-python/geventhttpclient/Manifest
@@ -1,4 +1,3 @@
DIST geventhttpclient-1.4.5.tar.gz 58183 BLAKE2B 48d44048e7040552824ed19ac49c6dda41536ffded56bae0d942c06f111a327a1d571872f35f388853b479ea1aaa6de518f86e7ee72e362360492530ade65131 SHA512 9ffe00c79b145dab104e1dce336e072060f315d9bee880daf64b5f1f52e661d810dab9a60286320a7d30cf0e794465f201c039cc31fe7ec325cdb3a8350c9f7d
-DIST geventhttpclient-1.5.1.tar.gz 58398 BLAKE2B 9995e14c635b06f729d342b19187d4c4b935f903038950fc05e8d9260a341d3a551750c1cd46798ac2d97603d1dba449d4db3a51a44e49a1720ec23b1526edf8 SHA512 46fa5333149b86f5c4b5d06adfe5d49402d0220266c27507da1645f1da8a50562e142e37435a029bb4184c417e8a4123301a7dfc8769ce419e841afebc11247c
DIST geventhttpclient-1.5.2.tar.gz 58467 BLAKE2B ea9476038685458cade41150c33226b4355018b8a8c22623e96186ff922d7f6b9518ca4108afff3bcfd18167bf288ef7f6366528050e300d720ef0e7b15ef649 SHA512 1edf153f88b9a7a954f9acc316ac76f06f2599bd3cf11b4a8f1df7b500e884f304601aae6a1dca8cedf24d4f78793176814eadc8b2c60fa90769df649723146e
DIST geventhttpclient-1.5.3.tar.gz 58447 BLAKE2B a1cf529c6d40ee81ebe17cb066f2d837cf3d5ce2511bb735c1a63503b612c98c17c91f08de99d604c9ff6ebfa7e6502c338e7fbbc86de954ae7e559966aa8006 SHA512 9a0ed907f73f7f5ff8675502ef6fc82bff7b543d0a2d22e1eca5aba3592675a87fe09c48981f496b7f63a660e7eab5f68801ae74da8c33ac9d9bf55a0425eed1
diff --git a/dev-python/geventhttpclient/geventhttpclient-1.5.1.ebuild b/dev-python/geventhttpclient/geventhttpclient-1.5.1.ebuild
deleted file mode 100644
index 39d7cf97389c..000000000000
--- a/dev-python/geventhttpclient/geventhttpclient-1.5.1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="A high performance, concurrent HTTP client library for Python using gevent"
-HOMEPAGE="https://github.com/gwik/geventhttpclient"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-RDEPEND="
- app-arch/brotli[python,${PYTHON_USEDEP}]
- dev-python/certifi[${PYTHON_USEDEP}]
- dev-python/gevent[events(+),${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Avoid ModuleNotFoundError for tests we skip later
- sed -i '/^import dpkt.ssl/d' src/geventhttpclient/tests/test_ssl.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # These SNI tests require dpkt which is not in the tree
- src/geventhttpclient/tests/test_ssl.py::test_implicit_sni_from_host_in_ssl
- src/geventhttpclient/tests/test_ssl.py::test_implicit_sni_from_header_in_ssl
- src/geventhttpclient/tests/test_ssl.py::test_explicit_sni_in_ssl
- )
- # Append to sys.path to avoid ImportError
- # https://bugs.gentoo.org/667758
- # Skip tests which require internet access
- epytest --import-mode=append -m "not online"
-}