summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-12-28 22:51:58 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2021-12-28 22:53:36 -0600
commit49abc82442a8a94e4fae49b66c68dec5c3e9f036 (patch)
tree9e7e85b3a547df3ae26f69944fe36e47aa653c80 /dev-python/git-review/git-review-2.2.0.ebuild
parentapp-text/ocrad: don't call AR directly (diff)
downloadgentoo-49abc82442a8a94e4fae49b66c68dec5c3e9f036.tar.gz
gentoo-49abc82442a8a94e4fae49b66c68dec5c3e9f036.tar.bz2
gentoo-49abc82442a8a94e4fae49b66c68dec5c3e9f036.zip
dev-python/git-review: 2.2.0 bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/git-review/git-review-2.2.0.ebuild')
-rw-r--r--dev-python/git-review/git-review-2.2.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/git-review/git-review-2.2.0.ebuild b/dev-python/git-review/git-review-2.2.0.ebuild
new file mode 100644
index 000000000000..bd9c8e269e6b
--- /dev/null
+++ b/dev-python/git-review/git-review-2.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_7 python3_8 python3_9 )
+DISTUTILS_USE_SETUPTOOLS=
+
+inherit distutils-r1
+
+DESCRIPTION="Tool to submit code to Gerrit"
+HOMEPAGE="https://git.openstack.org/cgit/openstack-infra/git-review"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/opendev/${PN}.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-python/pbr-4.1.0[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/requests-1.1[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i -e '/manpages/,+1d' setup.cfg || die
+ distutils-r1_python_prepare_all
+}