summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2017-11-10 09:42:57 +0100
committerTiziano Müller <dev-zero@gentoo.org>2018-02-11 18:37:56 +0100
commitf238ae9f0d409d8bb44d9654c2c4dba30e8f593b (patch)
treed0d240d6492b71988a2014535d10351b1e2ebb20 /dev-python/gitdb2/gitdb2-2.0.3.ebuild
parentsys-auth/polkit-pkla-compat: fix HOMEPAGE and SRC_URI (diff)
downloadgentoo-f238ae9f0d409d8bb44d9654c2c4dba30e8f593b.tar.gz
gentoo-f238ae9f0d409d8bb44d9654c2c4dba30e8f593b.tar.bz2
gentoo-f238ae9f0d409d8bb44d9654c2c4dba30e8f593b.zip
dev-python/gitdb2: Version bump to 2.0.3
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-python/gitdb2/gitdb2-2.0.3.ebuild')
-rw-r--r--dev-python/gitdb2/gitdb2-2.0.3.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/gitdb2/gitdb2-2.0.3.ebuild b/dev-python/gitdb2/gitdb2-2.0.3.ebuild
new file mode 100644
index 000000000000..4aa4893fc037
--- /dev/null
+++ b/dev-python/gitdb2/gitdb2-2.0.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="GitDB is a pure-Python git object database"
+HOMEPAGE="
+ https://github.com/gitpython-developers/gitdb
+ https://pypi.python.org/pypi/gitdb2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ !dev-python/gitdb[${PYTHON_USEDEP}]
+ >=dev-python/smmap2-2.0.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+src_test() {
+ local i
+
+ mkdir "${T}"/repo || die
+ cd "${T}"/repo || die
+
+ for (( i = 0; i < 2500; ++i )); do
+ echo "${i}" > file"${i}" || die
+ done
+
+ git init || die
+ git config user.email "you@example.com" || die
+ git config user.name "Your Name" || die
+ git add -A || die
+ git commit -q -m ".." || die
+ git clone --bare "${T}"/repo "${T}"/repo.git || die
+ cd "${S}" || die
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ #TRAVIS=1 disables performance tests which rely on the gitdb repo
+ local -x TRAVIS=1
+ local -x GITDB_TEST_GIT_REPO_BASE="${T}"/repo.git
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}