summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-17 22:45:02 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-17 22:48:16 -0500
commitadaba2201d77d12bb8d0ed72fc92b8619ab00453 (patch)
tree8e549bb3e4bbe96439e0a72a5b9503fff96b5f3a /dev-python/glance_store
parentdev-python/oslo-vmware: 3.7.0 bump (diff)
downloadgentoo-adaba2201d77d12bb8d0ed72fc92b8619ab00453.tar.gz
gentoo-adaba2201d77d12bb8d0ed72fc92b8619ab00453.tar.bz2
gentoo-adaba2201d77d12bb8d0ed72fc92b8619ab00453.zip
dev-python/glance_store: 2.3.0 bump
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/glance_store')
-rw-r--r--dev-python/glance_store/Manifest1
-rw-r--r--dev-python/glance_store/glance_store-2.3.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/glance_store/Manifest b/dev-python/glance_store/Manifest
index 6dad089b5a3c..a71799a176ba 100644
--- a/dev-python/glance_store/Manifest
+++ b/dev-python/glance_store/Manifest
@@ -1 +1,2 @@
DIST glance_store-1.0.1.tar.gz 185244 BLAKE2B 4841bf9db07df06fe4f0dedc9f06e6aa768118aa363946b3145c90f7d58f452c3b1f419bd3545681161481d88566922f8c3f4eb0612c77a0679729fc460d6169 SHA512 77144f41996e8fcc7b5ec3e4246305e6887082a8f62a84c73d0b546c9f635e8f43b95e45a5e3303e504c01ed3608de6358398eeffee226f640035df2f792dc8d
+DIST glance_store-2.3.0.tar.gz 212933 BLAKE2B 69f54fbb44de0e6e9608e38cf0b43ee6fb7df7758d19b6dee6f15fb00a25ce885610ef9c779d2138c08f5d3a28760121ef66edade0b23619685d5f985433247f SHA512 59499c1fa8b596faba0918219b76e5e7d51f6c7e94d14b99f28b2a9f87b456e638bd42fe33124ae9507043a975db6e5b5762e5979258db35b772f41a08d59be6
diff --git a/dev-python/glance_store/glance_store-2.3.0.ebuild b/dev-python/glance_store/glance_store-2.3.0.ebuild
new file mode 100644
index 000000000000..36beee1e75fb
--- /dev/null
+++ b/dev-python/glance_store/glance_store-2.3.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A library for glance"
+HOMEPAGE="https://github.com/openstack/glance_store"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="cinder swift vmware"
+
+DEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/pbr-1.8[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.18.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-serialization-1.19.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ cinder? (
+ >=dev-python/python-cinderclient-4.1.0[${PYTHON_USEDEP}]
+ >=dev-python/os-brick-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-rootwrap-5.8.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-privsep-1.23.0[${PYTHON_USEDEP}]
+ )
+ swift? (
+ >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/python-swiftclient-3.2.0[${PYTHON_USEDEP}]
+ )
+ vmware? ( >=dev-python/oslo-vmware-2.17.0[${PYTHON_USEDEP}] )
+"