summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-08-04 13:46:53 +0300
committerMart Raudsepp <leio@gentoo.org>2019-08-04 13:46:53 +0300
commit974b83e7f227237f33d554eec706e4813e7bff69 (patch)
tree9df565e0b7f8d91bdea66ddf0da1fcba34829350 /dev-python/gnome-python-extras-base/gnome-python-extras-base-2.25.3-r1.ebuild
parentx11-libs/vte: fix vala:0.44 compatibility properly (diff)
downloadgentoo-974b83e7f227237f33d554eec706e4813e7bff69.tar.gz
gentoo-974b83e7f227237f33d554eec706e4813e7bff69.tar.bz2
gentoo-974b83e7f227237f33d554eec706e4813e7bff69.zip
dev-python/gnome-python*-base: Fix python eclass usage
Closes: https://bugs.gentoo.org/691406 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-python/gnome-python-extras-base/gnome-python-extras-base-2.25.3-r1.ebuild')
-rw-r--r--dev-python/gnome-python-extras-base/gnome-python-extras-base-2.25.3-r1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/gnome-python-extras-base/gnome-python-extras-base-2.25.3-r1.ebuild b/dev-python/gnome-python-extras-base/gnome-python-extras-base-2.25.3-r1.ebuild
index cfcd4a3af74e..6744b4c211c5 100644
--- a/dev-python/gnome-python-extras-base/gnome-python-extras-base-2.25.3-r1.ebuild
+++ b/dev-python/gnome-python-extras-base/gnome-python-extras-base-2.25.3-r1.ebuild
@@ -4,16 +4,17 @@
EAPI="5"
PYTHON_COMPAT=( python2_7 )
-inherit versionator autotools eutils gnome2 python-any-r1
+inherit autotools eapi7-ver eutils gnome2 python-r1
# This ebuild does nothing -- we just want to get the pkgconfig file installed
MY_PN="gnome-python-extras"
DESCRIPTION="Provides python the base files for the Gnome Python Desktop bindings"
HOMEPAGE="http://pygtk.org/"
-PVP="$(get_version_component_range 1-2)"
+PVP="$(ver_cut 1-2)"
SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP}/${MY_PN}-${PV}.tar.bz2"
IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
LICENSE="LGPL-2.1"
SLOT="0"
RESTRICT="test"
@@ -21,7 +22,8 @@ RESTRICT="test"
# From the gnome-python-extras eclass
RDEPEND=">=x11-libs/gtk+-2.4:2
>=dev-libs/glib-2.6:2
- $(python_gen_any_dep '>=dev-python/pygtk-2.10.3:2[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+ >=dev-python/pygtk-2.10.3:2[${PYTHON_USEDEP}]
!<=dev-python/gnome-python-extras-2.19.1-r2"
DEPEND="${RDEPEND}
virtual/pkgconfig