summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-09 00:48:49 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-09 00:51:38 +0200
commit1b733bba4d9ba3baa6eed6049018f7ac52401756 (patch)
tree03bae52950b41b82d6382d0f4fafc371d1b480ff /dev-python/google-api-core/google-api-core-1.30.0.ebuild
parentdev-python/google-auth: Bump to 1.30.2 (diff)
downloadgentoo-1b733bba4d9ba3baa6eed6049018f7ac52401756.tar.gz
gentoo-1b733bba4d9ba3baa6eed6049018f7ac52401756.tar.bz2
gentoo-1b733bba4d9ba3baa6eed6049018f7ac52401756.zip
dev-python/google-api-core: Bump to 1.30.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-api-core/google-api-core-1.30.0.ebuild')
-rw-r--r--dev-python/google-api-core/google-api-core-1.30.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/google-api-core/google-api-core-1.30.0.ebuild b/dev-python/google-api-core/google-api-core-1.30.0.ebuild
new file mode 100644
index 000000000000..1b0c182a7a3c
--- /dev/null
+++ b/dev-python/google-api-core/google-api-core-1.30.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Core Library for Google Client Libraries"
+HOMEPAGE="https://github.com/googleapis/python-api-core
+ https://googleapis.dev/python/google-api-core/latest"
+SRC_URI="https://github.com/googleapis/${PN//google/python}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P//google/python}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/googleapis-common-protos[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.25.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${D}" -name '*.pth' -delete || die
+}