summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-16 09:08:05 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-16 09:46:06 +0100
commit1f418516f1e21546396c7b524578778b184ed474 (patch)
treeeff7eb83855ab66eff731e33f4e4e6ec2e56cf71 /dev-python/google-api-core
parentdev-python/django-debug-toolbar: Bump to 3.2.4 (diff)
downloadgentoo-1f418516f1e21546396c7b524578778b184ed474.tar.gz
gentoo-1f418516f1e21546396c7b524578778b184ed474.tar.bz2
gentoo-1f418516f1e21546396c7b524578778b184ed474.zip
dev-python/google-api-core: Bump to 2.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-api-core')
-rw-r--r--dev-python/google-api-core/Manifest1
-rw-r--r--dev-python/google-api-core/google-api-core-2.3.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/google-api-core/Manifest b/dev-python/google-api-core/Manifest
index 8fb2f11472a6..a0eb2b496d77 100644
--- a/dev-python/google-api-core/Manifest
+++ b/dev-python/google-api-core/Manifest
@@ -1,2 +1,3 @@
DIST google-api-core-2.2.2.tar.gz 140701 BLAKE2B 4e90db4311fc88d3fc8e29d6d8f11ae1424000c0e293f219d679984ec4a2c1bbbaf72d734b937d6916302f3a9a8b1cb369dd719972f4eb2d3f7264bf16ffbc7f SHA512 9b307c8ebd224b7614bd1d9f48d752852929b726c04df24f81e0b1b601f9a14d10654e9ef53b6a5ab677e8e57256f87b8683fa4dde0585f9c2e6d313d29d53fe
DIST google-api-core-2.3.0.tar.gz 155449 BLAKE2B 4aba324a18c8b6f9b9afd223688771fc6a57ee71f550736cfb5c9fac861a6a84369eb4e6ebec0664241590624c52cd0bcc8762afeb230debc16f0849fde049bf SHA512 f85c9279822ab818aa9d183bc930e61be9cfb2e65ab6a46fcd8aaab2531b4258c6247b02fb8f4f29841d9ab13ca33e129198589cbc37b3c77677a72e72635285
+DIST google-api-core-2.3.1.tar.gz 156495 BLAKE2B fdc7f7d8457b96947181eee9992c5e51bbd18f9740a0415a32d4d0f45ade9c0c784e01f0aa78fe0dbbf3717ee860e78d6b4d1c5f154361afbf919abe033e5380 SHA512 ab1c333727e666f920d81186e6213d440052021d952efcb47eac487d10ab33a2e1116278925e54bfb3468de70c18837a0e241ba3426af09728ea59a725789a29
diff --git a/dev-python/google-api-core/google-api-core-2.3.1.ebuild b/dev-python/google-api-core/google-api-core-2.3.1.ebuild
new file mode 100644
index 000000000000..f67642816e93
--- /dev/null
+++ b/dev-python/google-api-core/google-api-core-2.3.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Core Library for Google Client Libraries"
+HOMEPAGE="https://github.com/googleapis/python-api-core/
+ https://googleapis.dev/python/google-api-core/latest/index.html"
+SRC_URI="https://github.com/googleapis/${PN//google/python}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P//google/python}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/googleapis-common-protos[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.25.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+"
+# grpcio support is broken if grpcio-status is not installed,
+# and we do not package the latter
+BDEPEND="
+ test? (
+ !!dev-python/grpcio
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+
+EPYTEST_DESELECT=(
+ # TODO: package proto-plus
+ tests/unit/test_protobuf_helpers.py::test_field_mask_ignore_trailing_underscore
+ tests/unit/test_protobuf_helpers.py::test_field_mask_ignore_trailing_underscore_with_nesting
+)
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${D}" -name '*.pth' -delete || die
+}