summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-17 08:52:20 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-17 08:52:20 +0200
commit213e65c5740d0e0e2473a6a94b5e01dc173ef0db (patch)
tree78ec77ebea85650495719dd5a40f66be8b254f71 /dev-python/google-api-core
parentdev-python/jupyter_console: Remove old (diff)
downloadgentoo-213e65c5740d0e0e2473a6a94b5e01dc173ef0db.tar.gz
gentoo-213e65c5740d0e0e2473a6a94b5e01dc173ef0db.tar.bz2
gentoo-213e65c5740d0e0e2473a6a94b5e01dc173ef0db.zip
dev-python/google-api-core: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-api-core')
-rw-r--r--dev-python/google-api-core/Manifest1
-rw-r--r--dev-python/google-api-core/google-api-core-2.5.0.ebuild65
2 files changed, 0 insertions, 66 deletions
diff --git a/dev-python/google-api-core/Manifest b/dev-python/google-api-core/Manifest
index e61c48d75451..6488ebdc80c6 100644
--- a/dev-python/google-api-core/Manifest
+++ b/dev-python/google-api-core/Manifest
@@ -1,2 +1 @@
-DIST google-api-core-2.5.0.tar.gz 160336 BLAKE2B 5a3050dcb2e58c068c67cd6263b297ea84e4a47784c750e7ed87077bf46314730698eda2eaa8305a99a55b539b8886dfbbeeb9dc9838748fa941db6785212f36 SHA512 92b570195db21dded50b220e350e518c13101ab3e247bcbb3d3f5701e722c6dc81312443889360fdef1485edf1d5ef486bfeecf56092844cea81b61c7c527728
DIST google-api-core-2.7.1.tar.gz 163942 BLAKE2B 0b28e8dd8607ed6a64a3715c14e321f74d18abc09bc2eee5c6d080936160ea9d6839f1acf9589667c86a688e4e02038cc204f25d0b7cab3e3ed3af2463f31abb SHA512 2264eec00309f272ecca278e8f310bca4be64cfcec94c05fa96a7a8ae350fce0ae9931fbb27aae71e89393289cdbef782631a6766e85d5aee449e903e70f0817
diff --git a/dev-python/google-api-core/google-api-core-2.5.0.ebuild b/dev-python/google-api-core/google-api-core-2.5.0.ebuild
deleted file mode 100644
index f2c7aa1eb8f4..000000000000
--- a/dev-python/google-api-core/google-api-core-2.5.0.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 2020-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Core Library for Google Client Libraries"
-HOMEPAGE="https://github.com/googleapis/python-api-core/
- https://googleapis.dev/python/google-api-core/latest/index.html"
-SRC_URI="https://github.com/googleapis/${PN//google/python}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${P//google/python}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-
-RDEPEND="
- dev-python/namespace-google[${PYTHON_USEDEP}]
- dev-python/protobuf-python[${PYTHON_USEDEP}]
- dev-python/googleapis-common-protos[${PYTHON_USEDEP}]
- >=dev-python/google-auth-1.25.0[${PYTHON_USEDEP}]
- >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
- <dev-python/requests-3[${PYTHON_USEDEP}]
-"
-# grpcio support is broken if grpcio-status is not installed,
-# and we do not package the latter
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/proto-plus[${PYTHON_USEDEP}]
- dev-python/rsa[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # failing due to missing grpcio-status
- tests/asyncio/test_grpc_helpers_async.py::test_wrap_unary_errors
- tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_raised
- tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_read
- tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_aiter
- tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_write
- tests/unit/test_grpc_helpers.py::test_wrap_unary_errors
- tests/unit/test_grpc_helpers.py::Test_StreamingResponseIterator::test___next___w_rpc_error
- tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_invocation
- tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_iterator_initialization
- tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_during_iteration
- # TODO
- tests/unit/test_operation.py::test_exception_with_error_code
-)
-
-python_compile() {
- distutils-r1_python_compile
- find "${BUILD_DIR}" -name '*.pth' -delete || die
-}
-
-python_test() {
- epytest -p no:aiohttp -p no:trio
-}