summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-27 07:13:59 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-27 08:10:29 +0200
commit401fd68cb2dbad38c9cc5b0c463a0553b89b452e (patch)
tree58f304f4d438487d6d227ddf793adaaf00b672e2 /dev-python/google-api-core
parentdev-python/googleapis-common-protos: Bump to 1.56.2 (diff)
downloadgentoo-401fd68cb2dbad38c9cc5b0c463a0553b89b452e.tar.gz
gentoo-401fd68cb2dbad38c9cc5b0c463a0553b89b452e.tar.bz2
gentoo-401fd68cb2dbad38c9cc5b0c463a0553b89b452e.zip
dev-python/google-api-core: Bump to 2.8.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-api-core')
-rw-r--r--dev-python/google-api-core/Manifest1
-rw-r--r--dev-python/google-api-core/google-api-core-2.8.1.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/google-api-core/Manifest b/dev-python/google-api-core/Manifest
index f8a0d18b2c5a..1c8963d8c4bc 100644
--- a/dev-python/google-api-core/Manifest
+++ b/dev-python/google-api-core/Manifest
@@ -2,3 +2,4 @@ DIST google-api-core-2.7.1.tar.gz 163942 BLAKE2B 0b28e8dd8607ed6a64a3715c14e321f
DIST google-api-core-2.7.2.tar.gz 164017 BLAKE2B d2f1c690527c750a819718043542ce853be7f135660dfe661db2ba315213ef4a9756eeab6f1854275044d4f1fed50d119c2914eb00e043b7d5b085dad426a26f SHA512 1fb420a41d603d576030d2b324036de10831035ce1505ba94dedc9e58ce354d0f23e1d3df8a4f2f5082147a1be49d93e10c2209a1407f90ffedfa74815730e14
DIST google-api-core-2.7.3.tar.gz 164219 BLAKE2B c394fd95bff3ac393174372e0c49f9a7974a006de6f14d07af7b15b4c531d6dae7af8c38e00263289a895cb9dae9ef23368d793f5ae3649b9b029337a72cc0ef SHA512 2bf49738216cd52dad2bdfb3367e370390c366b49a8c3c4f6f49a2a3f17b27120d99933b57c8eb8c9a1f0f25ef5ea6d876cf8c3c6c759d3585d625e57b1153f9
DIST google-api-core-2.8.0.tar.gz 164541 BLAKE2B a62aa242e99f2e554242db1bdfdedc5ab4eb7ddd0efb3758af33dcd7417ce964cb1c5d11547c26b03e92684507e1573d1cbdc158efa39060e59254fed3e12626 SHA512 5ad9c4b8f8d15645e18f4377396a073cb23b03e4357d3840bcfcdc5bb182731817bb1188b3dd7f37e4083d4d6d0cea3d46fadee23fc9011a2fe9ca67f505e245
+DIST python-api-core-2.8.1.gh.tar.gz 164630 BLAKE2B 88db73f210ae5ee4aa2e7382ea34ef59fb51f88e196622556327c130057b74594884bbe21719bf12cc6ddc9975cf12ac71fa24ac4dfde4681b4742af57702b5d SHA512 f3bfa476562428246203592b53c22e8e52af167af10b1fa68afb51fe6e8ca8090e9231e4c297847d12c201ca791aa80153bee07f72939bc65920260ec50b3d38
diff --git a/dev-python/google-api-core/google-api-core-2.8.1.ebuild b/dev-python/google-api-core/google-api-core-2.8.1.ebuild
new file mode 100644
index 000000000000..2ddf9d7fb8e4
--- /dev/null
+++ b/dev-python/google-api-core/google-api-core-2.8.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=python-api-core-${PV}
+DESCRIPTION="Core Library for Google Client Libraries"
+HOMEPAGE="
+ https://github.com/googleapis/python-api-core/
+ https://pypi.org/project/google-api-core/
+ https://googleapis.dev/python/google-api-core/latest/index.html
+"
+SRC_URI="
+ https://github.com/googleapis/python-api-core/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/googleapis-common-protos-1.56.2[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.25.0[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.15.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ !dev-python/namespace-google
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/proto-plus[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # failing due to missing grpcio-status
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_unary_errors
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_raised
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_read
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_aiter
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_write
+ tests/unit/test_grpc_helpers.py::test_wrap_unary_errors
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_invocation
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_iterator_initialization
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_during_iteration
+)
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+src_test() {
+ rm -r google || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ distutils_write_namespace google
+ epytest -p no:aiohttp -p no:trio tests
+}