summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2016-10-12 04:14:09 -0700
committerZac Medico <zmedico@gentoo.org>2016-10-12 04:14:09 -0700
commit41b1a6fdcc5d29c75d6f4a7d9cdd1d6556b0b856 (patch)
tree03da0f49559236cae45662c82dbf7b9730b3f44a /dev-python/google-api-python-client/google-api-python-client-1.5.3.ebuild
parentdev-python/uritemplate: add python3_5 to PYTHON_COMPAT (diff)
downloadgentoo-41b1a6fdcc5d29c75d6f4a7d9cdd1d6556b0b856.tar.gz
gentoo-41b1a6fdcc5d29c75d6f4a7d9cdd1d6556b0b856.tar.bz2
gentoo-41b1a6fdcc5d29c75d6f4a7d9cdd1d6556b0b856.zip
dev-python/google-api-python-client: version bump to 1.5.3
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-python/google-api-python-client/google-api-python-client-1.5.3.ebuild')
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-1.5.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/google-api-python-client-1.5.3.ebuild b/dev-python/google-api-python-client/google-api-python-client-1.5.3.ebuild
new file mode 100644
index 000000000000..fa427c26e85b
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-1.5.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_{4,5}} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="https://code.google.com/p/google-api-python-client/ https://github.com/google/google-api-python-client"
+SRC_URI="https://github.com/google/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/httplib2-0.8[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/oauth2client-2[${PYTHON_USEDEP}]
+ <dev-python/oauth2client-3[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-0.6[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+ <dev-python/six-2[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ export SKIP_GOOGLEAPICLIENT_COMPAT_CHECK=true
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests --verbosity=3 || die
+}