summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-02 22:49:14 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-02 23:00:04 +0200
commitc292b4a11c551419e9cdd7986db23bb2a4bbf73a (patch)
tree6dadacd2f2906768f4947ee2231dee44cab47996 /dev-python/google-api-python-client/google-api-python-client-2.19.1.ebuild
parentdev-python/transitions: Bump to 0.8.9 (diff)
downloadgentoo-c292b4a11c551419e9cdd7986db23bb2a4bbf73a.tar.gz
gentoo-c292b4a11c551419e9cdd7986db23bb2a4bbf73a.tar.bz2
gentoo-c292b4a11c551419e9cdd7986db23bb2a4bbf73a.zip
dev-python/google-api-python-client: Bump to 2.19.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-api-python-client/google-api-python-client-2.19.1.ebuild')
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.19.1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.19.1.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.19.1.ebuild
new file mode 100644
index 000000000000..2bf8009bdc63
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.19.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="https://github.com/googleapis/google-api-python-client"
+SRC_URI="https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ dev-python/google-api-core[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-4[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest
+
+src_prepare() {
+ find tests -name '*.py' -exec \
+ sed -i -e 's:unittest2 as ::' {} + || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local deselect=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ distutils_install_for_testing
+ epytest tests ${deselect[@]/#/--deselect }
+}