summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-30 07:50:13 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-30 07:50:13 +0200
commit8140123a2c405016ed81b3821171bd76a40edbba (patch)
tree6397081fc11cbb896b71f6e51c740cd34509e1a8 /dev-python/google-api-python-client
parentdev-python/google-api-core: Remove old (diff)
downloadgentoo-8140123a2c405016ed81b3821171bd76a40edbba.tar.gz
gentoo-8140123a2c405016ed81b3821171bd76a40edbba.tar.bz2
gentoo-8140123a2c405016ed81b3821171bd76a40edbba.zip
dev-python/google-api-python-client: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/Manifest2
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.13.0.ebuild53
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.17.0.ebuild51
3 files changed, 0 insertions, 106 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 82abc62586eb..0e43c0463f9d 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,4 +1,2 @@
-DIST google-api-python-client-2.13.0.tar.gz 25562934 BLAKE2B 6ce955995c0f2fa5d09e1c90e65d38a7f321421199f53957fb58934c1f067de03a48f47f1d161c9ad2cb852663316c5d0f873a32b9eedd7fffaa2b067d84ae05 SHA512 d2b0cf3c250a500e774970790390025119102e24eaf8c7a0c170139cf322c37f4c8cd3f406a41d18deb2597dfeb21e6304e173cfaafb4d6faeff23b2215d4072
DIST google-api-python-client-2.14.1.tar.gz 25415625 BLAKE2B 2b843a6ec6345e51c5a92c0285c2b8ae195928bec61b73033fbc64d8e55c34ae39d8d542534d89edac36d6ddc6c12b6acf11a25dbcbc06f72776799a70606659 SHA512 e22600b9b87d646775780d0f45043753e4dea24e898faf16ae49f2c91677282700b45de993d085923c006f2948747a6afa2e58b38f42f934f1602401faa30d22
-DIST google-api-python-client-2.17.0.tar.gz 26302010 BLAKE2B 1d4a63825b79ff252b318d988aaa572a7567c4b3e19d110ec480d03c4ffcd16b16a19c4b54f51288a21e34a3a280c8077aa983da8eacaad1f176fb485ea7e89c SHA512 1967539825490530bb4330940bf69bc1bb25035b2079797185bb359c350fc111188b188e2d21dbd0009f8658a6dbb11539beed2aa5ce03daa142d7cbd330e466
DIST google-api-python-client-2.18.0.tar.gz 26442309 BLAKE2B 84f0cadeed015e9e0cafa209f6256b6262822f7161728aa5eba88f0def718b11c555bd0d87867c1e1ebb02e93046cec068e4ac0f855c55b7abf34a8d51d42fdc SHA512 19b06a252c440d5bb8454fc79487f4009ff73a7bd4882b2d33a354d4c4f287a6ea09f30cff94df4c1d1e898ca237d8e118a7fd5e63022133338d944dcec1243c
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.13.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.13.0.ebuild
deleted file mode 100644
index 7de791ae07c3..000000000000
--- a/dev-python/google-api-python-client/google-api-python-client-2.13.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-inherit distutils-r1
-
-DESCRIPTION="Google API Client for Python"
-HOMEPAGE="https://github.com/googleapis/google-api-python-client"
-SRC_URI="https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-
-RDEPEND="
- >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
- <dev-python/httplib2-1[${PYTHON_USEDEP}]
- dev-python/google-api-core[${PYTHON_USEDEP}]
- >=dev-python/google-auth-1.16.0[${PYTHON_USEDEP}]
- >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
- >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
- <dev-python/uritemplate-4[${PYTHON_USEDEP}]
- >=dev-python/six-1.13.0[${PYTHON_USEDEP}]
- <dev-python/six-2[${PYTHON_USEDEP}]
- "
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/oauth2client[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/parameterized[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests --install pytest
-
-src_prepare() {
- find tests -name '*.py' -exec \
- sed -i -e 's:unittest2 as ::' {} + || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local deselect=(
- # require Internet access (and credentials)
- tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
- tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
- )
-
- distutils_install_for_testing
- epytest ${deselect[@]/#/--deselect }
-}
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.17.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.17.0.ebuild
deleted file mode 100644
index 2bf8009bdc63..000000000000
--- a/dev-python/google-api-python-client/google-api-python-client-2.17.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-inherit distutils-r1
-
-DESCRIPTION="Google API Client for Python"
-HOMEPAGE="https://github.com/googleapis/google-api-python-client"
-SRC_URI="https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-
-RDEPEND="
- >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
- <dev-python/httplib2-1[${PYTHON_USEDEP}]
- dev-python/google-api-core[${PYTHON_USEDEP}]
- >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
- >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
- >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
- <dev-python/uritemplate-4[${PYTHON_USEDEP}]
- "
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/oauth2client[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/parameterized[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests --install pytest
-
-src_prepare() {
- find tests -name '*.py' -exec \
- sed -i -e 's:unittest2 as ::' {} + || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local deselect=(
- # require Internet access (and credentials)
- tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
- tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
- )
-
- distutils_install_for_testing
- epytest tests ${deselect[@]/#/--deselect }
-}