summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-05-03 20:43:39 -0700
committerZac Medico <zmedico@gentoo.org>2017-05-03 21:13:28 -0700
commit069a239018b652d34e5469362e517f92bc189945 (patch)
treef5a9b8bb9e2220d2c540db6dd22f995eff184630 /dev-python/google-auth-httplib2/google-auth-httplib2-0.0.2.ebuild
parentdev-python/google-auth: add package (diff)
downloadgentoo-069a239018b652d34e5469362e517f92bc189945.tar.gz
gentoo-069a239018b652d34e5469362e517f92bc189945.tar.bz2
gentoo-069a239018b652d34e5469362e517f92bc189945.zip
dev-python/google-auth-httplib2: add package
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/google-auth-httplib2/google-auth-httplib2-0.0.2.ebuild')
-rw-r--r--dev-python/google-auth-httplib2/google-auth-httplib2-0.0.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/google-auth-httplib2/google-auth-httplib2-0.0.2.ebuild b/dev-python/google-auth-httplib2/google-auth-httplib2-0.0.2.ebuild
new file mode 100644
index 000000000000..049c2bdf9806
--- /dev/null
+++ b/dev-python/google-auth-httplib2/google-auth-httplib2-0.0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+EGIT_COMMIT="607e86011141e8885b1f52826d57c8b5ff588ffc"
+MY_PN=google-auth-library-python-httplib2
+DESCRIPTION="httplib2 Transport for Google Auth"
+HOMEPAGE="https://pypi.python.org/pypi/google-auth-httplib2 https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2"
+# PyPi tarball is missing unit tests
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/google-auth[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ )"
+
+S=${WORKDIR}/${MY_PN}-${EGIT_COMMIT}
+
+python_test() {
+ py.test -v || die "Tests failed under ${EPYTHON}"
+}