summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2019-12-25 19:33:33 +0800
committerJason Zaman <perfinion@gentoo.org>2019-12-26 10:40:13 +0800
commit5c8f4c07468c38a21ecebaa57f9b7d8f8e335d93 (patch)
tree593dbfb1dec6b547e33afc11099d4a93c0545bed /dev-python/google-auth-oauthlib
parentdev-python/requests-oauthlib: bump 1.3.0 (diff)
downloadgentoo-5c8f4c07468c38a21ecebaa57f9b7d8f8e335d93.tar.gz
gentoo-5c8f4c07468c38a21ecebaa57f9b7d8f8e335d93.tar.bz2
gentoo-5c8f4c07468c38a21ecebaa57f9b7d8f8e335d93.zip
dev-python/google-auth-oauthlib: bump 0.4.1
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'dev-python/google-auth-oauthlib')
-rw-r--r--dev-python/google-auth-oauthlib/Manifest1
-rw-r--r--dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.1.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/google-auth-oauthlib/Manifest b/dev-python/google-auth-oauthlib/Manifest
index 519330df1e45..2e85f5d92101 100644
--- a/dev-python/google-auth-oauthlib/Manifest
+++ b/dev-python/google-auth-oauthlib/Manifest
@@ -1 +1,2 @@
DIST google-auth-oauthlib-0.4.0.tar.gz 73664 BLAKE2B bc98af5a85b26ced36171dae4e9a498b08ddfb92cf557805a238d68fe8bc251c61be6f051db391f4c30fae0aacf139cd0cd88c3e42cdc73efeaaa36407c9496d SHA512 49760914c02b41b7252062c8cb99b133b342463aa2b66b42dd5f320320010425e6952009514cbf89a4704648113693b35db1d3aa3636fc1297a25e59635a7dd5
+DIST google-auth-oauthlib-0.4.1.tar.gz 18687 BLAKE2B 1c9028f6b4c306bbee51fba5b55950d129d56ff5154645a166998c0c720b125202731f1cfed60837b8103d56fcdeeb818e39491b243a8d761969f73d9f88f67b SHA512 123707139353db8e05c81138af834e35007d323f0e19ae79088ad5ca4be86dda6c0df91e2f7794711475227a60312fab9101c91b49817bf8b84866ea6374c943
diff --git a/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.1.ebuild b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.1.ebuild
new file mode 100644
index 000000000000..b16d9dabf656
--- /dev/null
+++ b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="https://pypi.org/project/google-auth-oauthlib/ https://github.com/googleapis/google-auth-library-python-oauthlib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/google-auth[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.7.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"