summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-24 08:23:14 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-24 08:35:18 +0100
commit9f84848e91519dd6c364a9e7d0df99306a2c7646 (patch)
tree66683472baa9f7adb34948f8773bcbe6689eb3a9 /dev-python/google-auth-oauthlib
parentdev-python/autobahn: Bump to 22.2.2 (diff)
downloadgentoo-9f84848e91519dd6c364a9e7d0df99306a2c7646.tar.gz
gentoo-9f84848e91519dd6c364a9e7d0df99306a2c7646.tar.bz2
gentoo-9f84848e91519dd6c364a9e7d0df99306a2c7646.zip
dev-python/google-auth-oauthlib: Bump to 0.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-auth-oauthlib')
-rw-r--r--dev-python/google-auth-oauthlib/Manifest1
-rw-r--r--dev-python/google-auth-oauthlib/google-auth-oauthlib-0.5.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/google-auth-oauthlib/Manifest b/dev-python/google-auth-oauthlib/Manifest
index 08f446786de0..4cf722bb0993 100644
--- a/dev-python/google-auth-oauthlib/Manifest
+++ b/dev-python/google-auth-oauthlib/Manifest
@@ -1 +1,2 @@
DIST google-auth-library-python-oauthlib-0.4.6.gh.tar.gz 50982 BLAKE2B 93980a69777089125bca9f583cae0b64f9facf699da3ac135561a9cf135122d9e22a6c0be3325d366dd77a2240fb16d5c63633a216cfee07b9fceb2239227c86 SHA512 a20a85c073a6208d72c8f6ceb34544241f599e716b1191bfc52bcc367797efc18d0e2b94d4e433cec692282b00428bcb4d7e73ed48a26e66d6005189d5dddb77
+DIST google-auth-library-python-oauthlib-0.5.0.gh.tar.gz 52118 BLAKE2B 596f9af156030b0dbc0a35c3946ab865370fa326176fc33b04d55aa5d99950718d275f69b399d9afe303ee84f9c5823571eb4c144353f17fe6a64bbca7a35e18 SHA512 7da0d1c5e8c20aee843798c317a2c1edd29caf98abaf8895e354e20279c45395de4a522e21f11dbbe9e67c3bd984ded101b0cde04519b9256d80bdc42501a71a
diff --git a/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.5.0.ebuild b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.5.0.ebuild
new file mode 100644
index 000000000000..931bd53ed2a7
--- /dev/null
+++ b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+MY_P=google-auth-library-python-oauthlib-${PV}
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://pypi.org/project/google-auth-oauthlib/
+ https://github.com/googleapis/google-auth-library-python-oauthlib"
+SRC_URI="
+ https://github.com/googleapis/google-auth-library-python-oauthlib/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/click-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.7.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest