summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-29 11:13:39 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-29 11:24:51 +0100
commit29cb80f1b5db1543252bd9441ea4d5304a821908 (patch)
treed06a931764625a726b82f75e32f70b7511ac0ed9 /dev-python/google-auth/google-auth-2.26.1.ebuild
parentdev-python/sphinx-bootstrap-theme: Add a test dep on sphinx (diff)
downloadgentoo-29cb80f1b5db1543252bd9441ea4d5304a821908.tar.gz
gentoo-29cb80f1b5db1543252bd9441ea4d5304a821908.tar.bz2
gentoo-29cb80f1b5db1543252bd9441ea4d5304a821908.zip
dev-python/google-auth: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-auth/google-auth-2.26.1.ebuild')
-rw-r--r--dev-python/google-auth/google-auth-2.26.1.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/google-auth/google-auth-2.26.1.ebuild b/dev-python/google-auth/google-auth-2.26.1.ebuild
deleted file mode 100644
index 300932aa0eee..000000000000
--- a/dev-python/google-auth/google-auth-2.26.1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Google Authentication Library"
-HOMEPAGE="
- https://github.com/googleapis/google-auth-library-python/
- https://pypi.org/project/google-auth/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 x86"
-
-RDEPEND="
- <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
- >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/grpcio[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/moto[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- dev-python/pyu2f[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_IGNORE=(
- # these are compatibility tests with oauth2client
- # disable them to unblock removal of that package
- tests/test__oauth2client.py
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
-
-python_compile() {
- distutils-r1_python_compile
- find "${BUILD_DIR}" -name '*.pth' -delete || die
-}