summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-05-12 20:18:30 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-05-12 21:00:31 -0700
commit47240f0c56597525b5eba99d8bea4efc993eff03 (patch)
treee2df8931cb5a9078de27dcb047436b153126ef46 /dev-python/google-auth
parentdev-python/uritemplate-3.0.1-r1: revbump, EAPI=7, py38, enable tests (diff)
downloadgentoo-47240f0c56597525b5eba99d8bea4efc993eff03.tar.gz
gentoo-47240f0c56597525b5eba99d8bea4efc993eff03.tar.bz2
gentoo-47240f0c56597525b5eba99d8bea4efc993eff03.zip
dev-python/google-auth-1.14.3: bump, add py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest1
-rw-r--r--dev-python/google-auth/google-auth-1.14.3.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index d950e9f182c2..42447d864668 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,2 +1,3 @@
DIST google-auth-1.0.1.tar.gz 133903 BLAKE2B 0a99dcdb37a195f24077162ea8191e2eb12aac0eec8e08d06f0b17aba9c4f5ed44f19ca41c737a249611ce02b98e03474d1e995909c5755222605e004d11fb1d SHA512 c10822c6b75700503a06a4b3a43a123d57605a043eb494bcb0232cc3941fc039d0803ed75be26d0da72fd4df613135c290fb3fdf82b0fa47d4fe0729462d80f4
+DIST google-auth-1.14.3.tar.gz 101964 BLAKE2B 096768066d02248a4b614e5ea1f1035c81714ef09f6fb43fdb3ecc308d7cadaf7ad821f1dca505389fd1c73eec5e0b2d233f71f54469c43a2616f64a15661f21 SHA512 e3b76907e50b4927aaa1d450a6133943ad736427a180023ea2c4639545449769136b9db89eae54456338f1cf5bbaaa5840a8cf3db92d54f9e96407ae8935a607
DIST google-auth-1.6.3.tar.gz 80899 BLAKE2B 71e9ef4fbb8803dbea96e1b9b3183f9bae8a9bd7e29eda1c9ee042c7abb3e5011ee4f461ddafd3295119e3a5a451892b8a38cb49702c59828baba1af35403c25 SHA512 47a3e9390428ffa58946c348d4e1a1bfe1290d6e06b75924bbacb37d5af929050690ef5c13820468de805646f4686c035b00dfe947c090d53568dd85d804af5e
diff --git a/dev-python/google-auth/google-auth-1.14.3.ebuild b/dev-python/google-auth/google-auth-1.14.3.ebuild
new file mode 100644
index 000000000000..2136981f343b
--- /dev/null
+++ b/dev-python/google-auth/google-auth-1.14.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="https://github.com/GoogleCloudPlatform/google-auth-library-python https://pypi.org/project/google-auth/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/cachetools-2.0.0[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # delete stray files included in the tarball
+ find "${S}"/tests -name '*.pyc' -delete || die
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}