summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-17 08:23:21 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-17 08:47:53 +0100
commitd43a25e436421800d22963c8e3a9aa04582f857c (patch)
tree94c5e774f2db2196199ab9ddd0e0b49c0d791ab7 /dev-python/google-auth
parentdev-python/responses: Bump to 0.13.0 (diff)
downloadgentoo-d43a25e436421800d22963c8e3a9aa04582f857c.tar.gz
gentoo-d43a25e436421800d22963c8e3a9aa04582f857c.tar.bz2
gentoo-d43a25e436421800d22963c8e3a9aa04582f857c.zip
dev-python/google-auth: Bump to 1.28.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest1
-rw-r--r--dev-python/google-auth/google-auth-1.28.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index 81d5e5529c9c..cead1bbdaf35 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,3 +1,4 @@
DIST google-auth-1.26.1.tar.gz 121927 BLAKE2B a24a9c5bca8de234213e75673ba49ef6b82eb3c165f9c3af276b3c4cd47750c6d8a53e46084ae71c8eadf474ec8f53c6a2469fd91e7bdcc87f61bd46bbf9704d SHA512 632cdada9975311ab079022da79334f69ae703183bef395c3b04fc86192c23032b9925259ade7c115883659b10a403661f2d9a39f3b5262b964d0b9f2947567f
DIST google-auth-1.27.0.tar.gz 157225 BLAKE2B d3bf40dac2f72d5bafa318c4ec07588a250d4d778b2313c22ef5f43742939b023c864f465f543bf9e8ef6fd0251ba4642f78151df2534e82f2f2a60f5894e63c SHA512 adadea669ddd18a345011602e9fd575fa7783aee0f786d6a42e97278e14a0acf721451d7171765c8aea4bfa5eaa63762f9f826a2d1d5f2c4ea6abbb7d7186ebb
DIST google-auth-1.27.1.tar.gz 157876 BLAKE2B 0a06451e8a800231972b5b167d45410791b38a1616043912befb5554eff217bd1af70bf34aaf455fe68f9f515ea143cb2446800231006c369005de6981f7f466 SHA512 d640bb5395f956fd3442ea31145af2d72855108bff6b11dfeecfd4b48ad4fa50efba838e423bace310e78bbae74860d6c031d4ee873a7ab6dd522eb49e3fbdab
+DIST google-auth-1.28.0.tar.gz 158266 BLAKE2B 7e1fcdd0a6d155c0170012d43062fa5df2c9dd731105990af6d055c0dc8f9c36917776876a25caedd4b804acf24cdebd93a0953a9f7642563a5abc05cc946156 SHA512 a02db23132950c99e032d8318451cd67127f1e9fc57731a8a76505a360d77484aef1859e54d8e4efa1bcde3f6f5379c3324d54cf57c0a95fb1fa7765f43e9581
diff --git a/dev-python/google-auth/google-auth-1.28.0.ebuild b/dev-python/google-auth/google-auth-1.28.0.ebuild
new file mode 100644
index 000000000000..400d08da8e38
--- /dev/null
+++ b/dev-python/google-auth/google-auth-1.28.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/cachetools-2.0.0[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}