summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-26 11:44:41 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-08 09:54:01 +0200
commit69bd074e34a19d59bb4d6cb0a16feadfa6b31458 (patch)
tree01213eaf2c9f9580278e3cddf20963284b37b47a /dev-python/gpep517/gpep517-6-r1.ebuild
parentdev-python/installer: Use DISTUTILS_USE_PEP517=no (diff)
downloadgentoo-69bd074e34a19d59bb4d6cb0a16feadfa6b31458.tar.gz
gentoo-69bd074e34a19d59bb4d6cb0a16feadfa6b31458.tar.bz2
gentoo-69bd074e34a19d59bb4d6cb0a16feadfa6b31458.zip
dev-python/gpep517: Use DISTUTILS_USE_PEP517=no
Closes: https://github.com/gentoo/gentoo/pull/25793 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/gpep517/gpep517-6-r1.ebuild')
-rw-r--r--dev-python/gpep517/gpep517-6-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/gpep517/gpep517-6-r1.ebuild b/dev-python/gpep517/gpep517-6-r1.ebuild
new file mode 100644
index 000000000000..ee64cb1d660f
--- /dev/null
+++ b/dev-python/gpep517/gpep517-6-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=no
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A backend script to aid installing Python packages in Gentoo"
+HOMEPAGE="
+ https://pypi.org/project/gpep517/
+ https://github.com/mgorny/gpep517/
+"
+SRC_URI="
+ https://github.com/mgorny/gpep517/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-python/installer-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.2.3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_install() {
+ python_domodule gpep517
+ python_newscript - gpep517 <<-EOF
+ #!${EPREFIX}/usr/bin/python
+ import sys
+ from gpep517.__main__ import main
+ sys.exit(main())
+ EOF
+}