summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-10 09:52:40 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-10 10:12:35 +0200
commit6d7945d316eb7ae1c6bd3e7eecfe1da8e392bfe0 (patch)
tree8e44e4e416db12a581b59758bdf617a97371828b /dev-python/gpep517
parentdev-libs/psimd: add to tree (diff)
downloadgentoo-6d7945d316eb7ae1c6bd3e7eecfe1da8e392bfe0.tar.gz
gentoo-6d7945d316eb7ae1c6bd3e7eecfe1da8e392bfe0.tar.bz2
gentoo-6d7945d316eb7ae1c6bd3e7eecfe1da8e392bfe0.zip
dev-python/gpep517: Bump to v6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/gpep517')
-rw-r--r--dev-python/gpep517/Manifest1
-rw-r--r--dev-python/gpep517/gpep517-6.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/gpep517/Manifest b/dev-python/gpep517/Manifest
index 0a6fdbf5e3ed..4c2c02a42328 100644
--- a/dev-python/gpep517/Manifest
+++ b/dev-python/gpep517/Manifest
@@ -1,2 +1,3 @@
DIST gpep517-3.gh.tar.gz 7074 BLAKE2B 99a499ae13b6aac41e86d11735f0e49a5dc921881a1efa94bee19bfd779af6827707d05d6407ed15e4a3a6b518c8c0b3f50901e3b12df41081930f83b288e461 SHA512 90f756f5a1d783e9d402e098162a70b363a0a81e331e810e5c89c3302bb5839032603252bad1c98c176a7828b70adfac967e39ba455dcd3a20097e74923980c8
DIST gpep517-5.gh.tar.gz 9568 BLAKE2B 7641ae7792a15be7241d9c02622b589a796a96c76894c29f37733e33820532042f6d5b8018ef021b487c299f3a28adf37949e96c38148d88c140ed6926e95f2b SHA512 3618f3d17cc367716c4813d75814ef295896f210ff32c13f1ef8ad8cde2120a30ba69705e14dbb1e5528bf5a348f9f8c5f5de8b416608cd496733e94afbeb2c6
+DIST gpep517-6.gh.tar.gz 9757 BLAKE2B f1b39f30b7d775330bddfd353610de7c26e34c5572cdaedbb078cc61c711e90e1c520b5e6e5532b0879ccc1eb7025a793c6f8d9745d93967eabbdd9edef69c6a SHA512 681108dab418d0d2d5b017f19bf8802479655f22eb6b72e9d78c6bbd2d08583751a465377c2006c507f0ea258d2d46bf9300865896af4458a763b56a86abe329
diff --git a/dev-python/gpep517/gpep517-6.ebuild b/dev-python/gpep517/gpep517-6.ebuild
new file mode 100644
index 000000000000..1c06fab5af2e
--- /dev/null
+++ b/dev-python/gpep517/gpep517-6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=manual
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A backend script to aid installing Python packages in Gentoo"
+HOMEPAGE="
+ https://pypi.org/project/gpep517/
+ https://github.com/mgorny/gpep517/
+"
+SRC_URI="
+ https://github.com/mgorny/gpep517/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-python/installer-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.2.3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+# do not use any build system to avoid circular deps
+python_compile() { :; }
+
+python_install() {
+ python_domodule gpep517
+ python_newscript - gpep517 <<-EOF
+ #!${EPREFIX}/usr/bin/python
+ import sys
+ from gpep517.__main__ import main
+ sys.exit(main())
+ EOF
+}