summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-09-22 01:16:04 +0200
committerDavid Seifert <soap@gentoo.org>2020-09-22 01:16:04 +0200
commit7180c63093c03ee0bba246ac657d13fbe4763a14 (patch)
tree48e2a268a697de467558674fa4c079b9d88caf5f /dev-python/graph-tool/graph-tool-9999.ebuild
parentdev-python/graph-tool: Version bump to 2.35 (diff)
downloadgentoo-7180c63093c03ee0bba246ac657d13fbe4763a14.tar.gz
gentoo-7180c63093c03ee0bba246ac657d13fbe4763a14.tar.bz2
gentoo-7180c63093c03ee0bba246ac657d13fbe4763a14.zip
dev-python/graph-tool: Sync live ebuild
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/graph-tool/graph-tool-9999.ebuild')
-rw-r--r--dev-python/graph-tool/graph-tool-9999.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-python/graph-tool/graph-tool-9999.ebuild b/dev-python/graph-tool/graph-tool-9999.ebuild
index 0b9a248e3700..20fbfe4e5570 100644
--- a/dev-python/graph-tool/graph-tool-9999.ebuild
+++ b/dev-python/graph-tool/graph-tool-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit check-reqs python-r1 toolchain-funcs
@@ -74,6 +74,11 @@ src_compile() {
}
src_install() {
- python_foreach_impl run_in_build_dir default
- find "${D}" -name '*.la' -delete || die
+ python_install() {
+ default
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir python_install
+
+ find "${ED}" -name '*.la' -delete || die
}