summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiago de Paula Peixoto <tiago@skewed.de>2022-01-07 16:00:44 +0100
committerDavid Seifert <soap@gentoo.org>2022-01-07 16:00:44 +0100
commitcb214cfb2fec1d071e46319b52d26eddf8ed1e35 (patch)
tree0d1bbb725dca9b73db6050914c6eba6ffbbf87cb /dev-python/graph-tool
parentapp-office/libreoffice-l10n: Drop 7.2.4.1 (diff)
downloadgentoo-cb214cfb2fec1d071e46319b52d26eddf8ed1e35.tar.gz
gentoo-cb214cfb2fec1d071e46319b52d26eddf8ed1e35.tar.bz2
gentoo-cb214cfb2fec1d071e46319b52d26eddf8ed1e35.zip
dev-python/graph-tool: Bump to 2.44
Closes: https://github.com/gentoo/gentoo/pull/23637 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/graph-tool')
-rw-r--r--dev-python/graph-tool/Manifest1
-rw-r--r--dev-python/graph-tool/graph-tool-2.44.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/graph-tool/Manifest b/dev-python/graph-tool/Manifest
index 0839a33f9a69..7a5039019fac 100644
--- a/dev-python/graph-tool/Manifest
+++ b/dev-python/graph-tool/Manifest
@@ -1 +1,2 @@
DIST graph-tool-2.43.tar.bz2 15170272 BLAKE2B 96570242cf2003c262024545a074bcd0f0cf9351b0c8c68035529d38d535411386d5440bb5166cfb70f24ba1540d9ce65324c659564f2ab50358dbd77bafed99 SHA512 e72dec9656acb2bb7ba43e19673fa4ff70ff4819e76bb5f00e9943e4cfe6a85f1e0eaa58c8be2921ebd783ef3d978294a347238f3700a457aaff8a98ea8ed4fc
+DIST graph-tool-2.44.tar.bz2 15149379 BLAKE2B d15413f4e8642b96f62d88631c216e600e24aa878b08a173f1a00f1700aa3c6f4b1b3f806956b811b209a2d42ec1178e2488946d96f056f528a046cbd6cc330a SHA512 b90dc541ec77f89fdbb64697ec5e200d9c7c4ec4b8849c75d008b83dab8f54c95bd230f5d72e32d656f86a201ab66eee25aa774b7983355f7af9304b52527e40
diff --git a/dev-python/graph-tool/graph-tool-2.44.ebuild b/dev-python/graph-tool/graph-tool-2.44.ebuild
new file mode 100644
index 000000000000..5078373af0e5
--- /dev/null
+++ b/dev-python/graph-tool/graph-tool-2.44.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit check-reqs python-r1 toolchain-funcs
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://git.skewed.de/count0/graph-tool.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://downloads.skewed.de/${PN}/${P}.tar.bz2"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="An efficient python module for manipulation and statistical analysis of graphs"
+HOMEPAGE="https://graph-tool.skewed.de/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="+cairo openmp"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/boost-1.70:=[context,python,${PYTHON_USEDEP}]
+ dev-libs/expat
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ sci-mathematics/cgal:=
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ cairo? (
+ dev-cpp/cairomm:0
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ )"
+DEPEND="${RDEPEND}
+ dev-cpp/sparsehash"
+BDEPEND="virtual/pkgconfig"
+
+# bug 453544
+CHECKREQS_DISK_BUILD="6G"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+ check-reqs_pkg_pretend
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+ python_copy_sources
+}
+
+src_configure() {
+ my_configure() {
+ econf \
+ --disable-static \
+ $(use_enable openmp) \
+ $(use_enable cairo) \
+ --with-boost-python="boost_${EPYTHON/./}"
+ }
+ python_foreach_impl run_in_build_dir my_configure
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir emake
+}
+
+src_install() {
+ my_python_install() {
+ default
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir my_python_install
+
+ find "${ED}" -name '*.la' -delete || die
+}