summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-03-02 19:26:51 -0500
committerAnthony G. Basile <blueness@gentoo.org>2018-03-02 19:28:07 -0500
commit558df35db548468ca90019d9f4bb34aeea74d8ae (patch)
tree00e9c466c1e3e59da4d81b6ea88904f6e01d43d9 /dev-python/graphql-core/graphql-core-2.0.0.ebuild
parentapp-office/libreoffice-l10n: Drop 6.0.1.1 (diff)
downloadgentoo-558df35db548468ca90019d9f4bb34aeea74d8ae.tar.gz
gentoo-558df35db548468ca90019d9f4bb34aeea74d8ae.tar.bz2
gentoo-558df35db548468ca90019d9f4bb34aeea74d8ae.zip
dev-python/graphql-core: initial commit
GraphQL for Python. See https://github.com/graphql-python/graphql-core
Diffstat (limited to 'dev-python/graphql-core/graphql-core-2.0.0.ebuild')
-rw-r--r--dev-python/graphql-core/graphql-core-2.0.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/graphql-core/graphql-core-2.0.0.ebuild b/dev-python/graphql-core/graphql-core-2.0.0.ebuild
new file mode 100644
index 000000000000..d73013847a56
--- /dev/null
+++ b/dev-python/graphql-core/graphql-core-2.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="GraphQL for Python"
+HOMEPAGE="https://github.com/graphql-python/graphql-core"
+SRC_URI="https://github.com/graphql-python/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/promises-2.1[${PYTHON_USEDEP}]
+ >=dev-python/Rx-1.6.0[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+RESTRICT="test"
+# Add these to test when we have them in the tree
+# test? (
+# =dev-python/pytest-3.0.2
+# =dev-python/pytest-django-2.9.1
+# =dev-python/pytest-cov-2.3.1
+# dev-python/coveralls
+# =dev-python/gevent-1.1-rc1
+# =dev-python/pytest-benchmark-3.0.0
+# =dev-python/pytest-mock-1.2
+# )