summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-26 18:19:47 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-26 18:21:37 +0100
commitb4aedf952e88c8cf8f638eebe502b528448e5d5b (patch)
tree1aff5ff47767f032436035ec4a5cf864e0605f57 /dev-python/graphviz
parentapp-admin/consul: Remove vulnerable versions (diff)
downloadgentoo-b4aedf952e88c8cf8f638eebe502b528448e5d5b.tar.gz
gentoo-b4aedf952e88c8cf8f638eebe502b528448e5d5b.tar.bz2
gentoo-b4aedf952e88c8cf8f638eebe502b528448e5d5b.zip
dev-python/graphviz: Migrate to PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/graphviz')
-rw-r--r--dev-python/graphviz/graphviz-0.19.1-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/graphviz/graphviz-0.19.1-r1.ebuild b/dev-python/graphviz/graphviz-0.19.1-r1.ebuild
new file mode 100644
index 000000000000..2b0922565359
--- /dev/null
+++ b/dev-python/graphviz/graphviz-0.19.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple Python interface for Graphviz"
+HOMEPAGE="https://graphviz.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+RDEPEND="
+ media-gfx/graphviz
+"
+BDEPEND="
+ app-arch/unzip
+ test? (
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-1.8[${PYTHON_USEDEP}]
+ media-gfx/graphviz[gts,pdf]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e 's:--cov --cov-report=term --cov-report=html::' \
+ -i setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ "${EPYTHON}" run-tests.py -vv -ra -l -Wdefault -p no:xdoctest ||
+ die "Tests failed with ${EPYTHON}"
+}