summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-20 10:49:00 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-20 11:36:11 +0200
commit8fa9709f7a7498fd4f5c899344269b9aca44aba8 (patch)
treeb344755e66e3693ea8d2f85cdc889dee7534adaa /dev-python/greenlet/greenlet-0.4.16-r1.ebuild
parentvirtual/python-greenlet: Remove python2 (diff)
downloadgentoo-8fa9709f7a7498fd4f5c899344269b9aca44aba8.tar.gz
gentoo-8fa9709f7a7498fd4f5c899344269b9aca44aba8.tar.bz2
gentoo-8fa9709f7a7498fd4f5c899344269b9aca44aba8.zip
dev-python/greenlet: Remove python2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/greenlet/greenlet-0.4.16-r1.ebuild')
-rw-r--r--dev-python/greenlet/greenlet-0.4.16-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/greenlet/greenlet-0.4.16-r1.ebuild b/dev-python/greenlet/greenlet-0.4.16-r1.ebuild
new file mode 100644
index 000000000000..5356c0a7b6ef
--- /dev/null
+++ b/dev-python/greenlet/greenlet-0.4.16-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Note: greenlet is built-in in pypy
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Lightweight in-process concurrent programming"
+HOMEPAGE="https://pypi.org/project/greenlet/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 -hppa -ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+distutils_enable_sphinx doc --no-autodoc
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS=${CFLAGS} CXXFLAGS=${CXXFLAGS}
+ append-flags -fno-strict-aliasing
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ "${PYTHON}" run-tests.py -n || die "Tests fail with ${EPYTHON}"
+}