summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-20 21:28:03 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-20 22:20:58 +0300
commitb88ebf44f18e782ef4225e79d8b0c2d1c6b66052 (patch)
tree152eabc6ee403cd48191b61ab89feb8baf4562a3 /dev-python/greenstalk/greenstalk-2.0.0.ebuild
parentdev-libs/libtomcrypt: fix paths in libtomcrypt.pc (diff)
downloadgentoo-b88ebf44f18e782ef4225e79d8b0c2d1c6b66052.tar.gz
gentoo-b88ebf44f18e782ef4225e79d8b0c2d1c6b66052.tar.bz2
gentoo-b88ebf44f18e782ef4225e79d8b0c2d1c6b66052.zip
dev-python/greenstalk: add 2.0.0, enable py3.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/greenstalk/greenstalk-2.0.0.ebuild')
-rw-r--r--dev-python/greenstalk/greenstalk-2.0.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/greenstalk/greenstalk-2.0.0.ebuild b/dev-python/greenstalk/greenstalk-2.0.0.ebuild
new file mode 100644
index 000000000000..a73826cc5bbc
--- /dev/null
+++ b/dev-python/greenstalk/greenstalk-2.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python 3 client for the beanstalkd work queue"
+HOMEPAGE="https://greenstalk.readthedocs.io/ https://github.com/justinmayhew/greenstalk"
+SRC_URI="
+ https://github.com/justinmayhew/greenstalk/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="test? ( app-misc/beanstalkd )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests.py
+}