summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriel Linder <linder.gabriel@gmail.com>2019-07-04 15:35:51 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-08-13 07:42:19 +0300
commit6c7bb2f938eb04b61b18a521739ca7af2aabf5ae (patch)
tree73f95cd0d1ffe58662d0d656c1deb989db9b3018 /dev-python/greenstalk
parentsys-apps/dbus-broker: bump to 21 (diff)
downloadgentoo-6c7bb2f938eb04b61b18a521739ca7af2aabf5ae.tar.gz
gentoo-6c7bb2f938eb04b61b18a521739ca7af2aabf5ae.tar.bz2
gentoo-6c7bb2f938eb04b61b18a521739ca7af2aabf5ae.zip
dev-python/greenstalk: bump to version 1.0.1.
Signed-off-by: Gabriel Linder <linder.gabriel@gmail.com> Package-Manager: Portage-2.3.69, Repoman-2.3.17 Closes: https://github.com/gentoo/gentoo/pull/12387 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/greenstalk')
-rw-r--r--dev-python/greenstalk/Manifest1
-rw-r--r--dev-python/greenstalk/greenstalk-1.0.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/greenstalk/Manifest b/dev-python/greenstalk/Manifest
index 0c5034c39f49..346b64ecbce9 100644
--- a/dev-python/greenstalk/Manifest
+++ b/dev-python/greenstalk/Manifest
@@ -1 +1,2 @@
DIST greenstalk-0.5.2.tar.gz 5317 BLAKE2B 1dd461f0a3a97210cad1c2a1957483477334c015e97184db22c3048c5152b4b7a2a0a5768cf79190c4f8c3115fc61557d3cb453fb56194db9906c5d29e7734e9 SHA512 a270e0c6aaab1ce93e695413c8c12a2546cffb5d3cd11b20679c1f4f8238a68b8e9ed59c0b1c5ec3ed3319d3cd32e8bfef68533e092645d2832546024dfa68db
+DIST greenstalk-1.0.1.tar.gz 12898 BLAKE2B fc0b90ba95b09e1490025175339c3f9eb7afed16db40ec34031305a3d487582fc7305b1990424f53a06887a34c30ab4f957db01a640576aa1c5db30511161c0f SHA512 8b57ec0c7fd3a60c24e8ddd7d51f31c0986317cbceb0f7045bbd720ca58e8f3c896f2f9924de7b1e8693844c814ecdebc020972d895468d1b0e7d055bf628b16
diff --git a/dev-python/greenstalk/greenstalk-1.0.1.ebuild b/dev-python/greenstalk/greenstalk-1.0.1.ebuild
new file mode 100644
index 000000000000..98bafab82c34
--- /dev/null
+++ b/dev-python/greenstalk/greenstalk-1.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="A Python 3 client for the beanstalkd work queue"
+HOMEPAGE="https://greenstalk.readthedocs.io/ https://github.com/mayhewj/greenstalk"
+SRC_URI="https://github.com/mayhewj/greenstalk/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ test? (
+ app-misc/beanstalkd
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ pytest -v tests.py || die
+}