summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2018-11-14 19:18:19 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-11-14 19:21:07 -0800
commit0ba9c1b4e84f18442d8894358ca3065d36db3046 (patch)
tree2a0181d3e455aea865af7a9a717617dbf3e1936d /dev-python/grpcio-testing/grpcio-testing-1.16.1.ebuild
parentdev-python/grpcio-tools: version bump to 1.16.1 (diff)
downloadgentoo-0ba9c1b4e84f18442d8894358ca3065d36db3046.tar.gz
gentoo-0ba9c1b4e84f18442d8894358ca3065d36db3046.tar.bz2
gentoo-0ba9c1b4e84f18442d8894358ca3065d36db3046.zip
dev-python/grpcio-testing: version bump to 1.16.1
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-python/grpcio-testing/grpcio-testing-1.16.1.ebuild')
-rw-r--r--dev-python/grpcio-testing/grpcio-testing-1.16.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/grpcio-testing/grpcio-testing-1.16.1.ebuild b/dev-python/grpcio-testing/grpcio-testing-1.16.1.ebuild
new file mode 100644
index 000000000000..85f8ae2dfefd
--- /dev/null
+++ b/dev-python/grpcio-testing/grpcio-testing-1.16.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Testing utilities for gRPC Python"
+HOMEPAGE="https://grpc.io"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="~dev-python/grpcio-${PV}[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"