summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor V. Kovalenko <igor.v.kovalenko@gmail.com>2022-03-17 21:53:34 +0300
committerSam James <sam@gentoo.org>2022-03-18 00:31:41 +0000
commit3bbfabcbf72ad21914c56e510158935e3bafbe89 (patch)
treeb10a0a20b4e664ca657361fab08283bc6926fc77 /dev-python/gst-python
parentmedia-sound/pulseaudio: Add USE=aptx dependency on gst-plugins-openaptx (diff)
downloadgentoo-3bbfabcbf72ad21914c56e510158935e3bafbe89.tar.gz
gentoo-3bbfabcbf72ad21914c56e510158935e3bafbe89.tar.bz2
gentoo-3bbfabcbf72ad21914c56e510158935e3bafbe89.zip
media-libs/gstreamer: Version bump, 1.18.6
Bug: https://bugs.gentoo.org/835368 Signed-off-by: Igor V. Kovalenko <igor.v.kovalenko@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/24625 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/gst-python')
-rw-r--r--dev-python/gst-python/Manifest1
-rw-r--r--dev-python/gst-python/gst-python-1.18.6.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/gst-python/Manifest b/dev-python/gst-python/Manifest
index 13d2762e955a..55403f8f4c75 100644
--- a/dev-python/gst-python/Manifest
+++ b/dev-python/gst-python/Manifest
@@ -1,3 +1,4 @@
DIST gst-python-1.16.3.tar.xz 419932 BLAKE2B 3c3d7d8dbde7d77d57e340c68503c436ab03f8768be4dd67561b13712bf88d7f8025118cf6a2ff115fbd41b28dc9a3208f612d1b72bf449fd7b23be4437f837f SHA512 2b038c4fc4891ddcf09e58c9e3e8d8462c150589dbb8a1f8d0a1266cffe49fd83531b2eb97cd57baab0f416a2bb1ba81383b55bb953545f3eedc50b6895986c4
DIST gst-python-1.18.4.tar.xz 158252 BLAKE2B 2fd60d2d451ae572cee2f7e9158e9c06e82cdd56c4fc70d2731aa0a46a21e495321ec02c97ecd9a946278ce9b7290a290b9f2bc13184582c1f8ff19e874d0e3a SHA512 6b9df9e4faaeb030f0596c9e52262c0f82b8854faf821497a840a762913dccb005321c60565754ef571e34976fcda481a41aefbbd486c2932377a95121433bf5
+DIST gst-python-1.18.6.tar.xz 163648 BLAKE2B 2a72d323f3620b976f537d91ac579824c65a112cd7a599b75f8ee6859ea2dcfeaf327a0dd90e1072071d036b6e7a4bd14fbd737ea95e42a1dd8868f05e6a8936 SHA512 312a141bc57a00496c34445648f11c8d61800fde0d5aefcc51bd296f6aafb9556e3ebed71904d262be6134c4b20eda30e025badddc977fdceb65b72ab788497e
DIST gst-python-1.20.1.tar.xz 151020 BLAKE2B 49d6730eeff90cc967e96fc1c9600f82690ff1136e46f65777d057880b239c65c6d88aa519a7558af94822f9ea57faf9b55a11c27bf9b8b567c1cea3fbbdfbf0 SHA512 16819b7b8c564af8d0cc5f3d5a64921c45523865d705d5f4580bf644aeaacf24fd1922f27c3729e8334e710d318646ee5250ac26045f863fedaf1c8481724750
diff --git a/dev-python/gst-python/gst-python-1.18.6.ebuild b/dev-python/gst-python/gst-python-1.18.6.ebuild
new file mode 100644
index 000000000000..5df02dbb593b
--- /dev/null
+++ b/dev-python/gst-python/gst-python-1.18.6.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit meson python-r1 xdg-utils
+
+DESCRIPTION="A Python Interface to GStreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+SRC_URI="https://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=media-libs/gstreamer-${PV}:1.0[introspection]
+ >=media-libs/gst-plugins-base-${PV}:1.0[introspection]
+ >=dev-python/pygobject-3.8:3[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ # Avoid building & testing plugin - it must NOT be multi-python as gst-inspect will map in all libpython.so versions and crash or behave mysteriously.
+ # Python plugin support is of limited use (GIL gets in the way). If it's ever requested or needed, it should be a
+ # separate python-single-r1 media-plugins/gst-plugins-python package that only builds the plugin directory.
+ sed -e '/subdir.*plugin/d' -i meson.build || die
+ sed -e '/test_plugin.py/d' -i testsuite/meson.build || die
+
+ xdg_environment_reset
+}
+
+src_configure() {
+ configuring() {
+ meson_src_configure \
+ -Dpython="${EPYTHON}"
+ }
+ python_foreach_impl configuring
+}
+
+src_compile() {
+ python_foreach_impl meson_src_compile
+}
+
+src_test() {
+ python_foreach_impl meson_src_test
+}
+
+src_install() {
+ installing() {
+ meson_src_install
+ python_optimize
+ }
+ python_foreach_impl installing
+}