summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-19 05:24:43 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-19 05:30:30 +0100
commit67a1b6a5070e50d0eb35771f24897cc0763f5ee2 (patch)
treef759e0fc975669c3db4c35df6730dd616197022f /dev-python/guessit/guessit-3.7.0.ebuild
parentdev-python/nbclassic: Bump to 0.5.2 (diff)
downloadgentoo-67a1b6a5070e50d0eb35771f24897cc0763f5ee2.tar.gz
gentoo-67a1b6a5070e50d0eb35771f24897cc0763f5ee2.tar.bz2
gentoo-67a1b6a5070e50d0eb35771f24897cc0763f5ee2.zip
dev-python/guessit: Bump to 3.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/guessit/guessit-3.7.0.ebuild')
-rw-r--r--dev-python/guessit/guessit-3.7.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/guessit/guessit-3.7.0.ebuild b/dev-python/guessit/guessit-3.7.0.ebuild
new file mode 100644
index 000000000000..7ce7c173e6ad
--- /dev/null
+++ b/dev-python/guessit/guessit-3.7.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python library for guessing information from video filenames"
+HOMEPAGE="
+ https://github.com/guessit-io/guessit/
+ https://pypi.org/project/guessit/
+"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/babelfish-0.5.5[${PYTHON_USEDEP}]
+ >=dev-python/rebulk-3.2.0[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Disable benchmarks as they require unavailable pytest-benchmark.
+ guessit/test/test_benchmark.py
+)