summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-06 09:15:36 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-06 11:58:53 +0100
commite60afacfe06d51d25f5adc359f080c42d9cd4607 (patch)
tree5f55f51f5c3bec6422d19f730a59be276019eed7 /dev-python/guessit
parentdev-python/imageio: Bump to 2.10.3 (diff)
downloadgentoo-e60afacfe06d51d25f5adc359f080c42d9cd4607.tar.gz
gentoo-e60afacfe06d51d25f5adc359f080c42d9cd4607.tar.bz2
gentoo-e60afacfe06d51d25f5adc359f080c42d9cd4607.zip
dev-python/guessit: Bump to 3.4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/guessit')
-rw-r--r--dev-python/guessit/Manifest1
-rw-r--r--dev-python/guessit/guessit-3.4.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/guessit/Manifest b/dev-python/guessit/Manifest
index e43ac4561590..4c12fc779f46 100644
--- a/dev-python/guessit/Manifest
+++ b/dev-python/guessit/Manifest
@@ -1 +1,2 @@
DIST guessit-3.3.1.tar.gz 156178 BLAKE2B 190b61eb98c4945eb2e14bbc3387a2eabff4e0f2fccf42f3b957d2b081d83d96333f3931837ad77d6b09c12aaa174eb8adf993d62ab9de7b74d8f0c55282a77c SHA512 42c87525ea2d9c808e30b50db674862f5362f26b95ba5e6bc163df03a261d9b24daf4b4d525677d3e6d53e8e7f637c3d9e0ba3f25f4397e0658b618f50a3248b
+DIST guessit-3.4.1.tar.gz 165594 BLAKE2B a05b272efd3304dc7f9e1ae6bc6595e5dc43a1cb68d96cebcd2817deced508cc24771235bcfb4dd9aec7aa41857cde138fed110e3b921aca7dc8cc15f750ba0e SHA512 2e42f93d4302f9586015bac9b11ebf0fd819305e02b869b6f398f494c0a979fd7d6857f9e036656d419c937e3f723a80cf0211ae1068edbfa3c7f9e1fdce182c
diff --git a/dev-python/guessit/guessit-3.4.1.ebuild b/dev-python/guessit/guessit-3.4.1.ebuild
new file mode 100644
index 000000000000..3570c4dabd81
--- /dev/null
+++ b/dev-python/guessit/guessit-3.4.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python library for guessing information from video filenames"
+HOMEPAGE="https://github.com/guessit-io/guessit
+ https://pypi.org/project/guessit/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/babelfish-0.5.5[${PYTHON_USEDEP}]
+ >=dev-python/rebulk-3[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Disable benchmarks as they require unavailable pytest-benchmark.
+ rm guessit/test/test_benchmark.py || die
+ sed -i -e "s|'pytest-benchmark',||g" setup.py || die
+
+ # Disable unconditional dependency on dev-python/pytest-runner.
+ sed -i -e "s|'pytest-runner'||g" setup.py || die
+
+ distutils-r1_python_prepare_all
+}