summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-24 05:39:12 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-24 05:39:12 +0100
commit33d2a521bd14b0d765b0ea7b8faddbdd12127911 (patch)
tree1f730a6178a8eb3d9867c8df2188a5a2ce90eba5 /dev-python/h5py/h5py-3.7.0.ebuild
parentdev-util/stripe-mock: Remove old (diff)
downloadgentoo-33d2a521bd14b0d765b0ea7b8faddbdd12127911.tar.gz
gentoo-33d2a521bd14b0d765b0ea7b8faddbdd12127911.tar.bz2
gentoo-33d2a521bd14b0d765b0ea7b8faddbdd12127911.zip
dev-python/h5py: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/h5py/h5py-3.7.0.ebuild')
-rw-r--r--dev-python/h5py/h5py-3.7.0.ebuild74
1 files changed, 0 insertions, 74 deletions
diff --git a/dev-python/h5py/h5py-3.7.0.ebuild b/dev-python/h5py/h5py-3.7.0.ebuild
deleted file mode 100644
index 4bde6fa3be73..000000000000
--- a/dev-python/h5py/h5py-3.7.0.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Simple Python interface to HDF5 files"
-HOMEPAGE="
- https://www.h5py.org/
- https://github.com/h5py/h5py/
- https://pypi.org/project/h5py/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~riscv x86 ~amd64-linux ~x86-linux"
-# disable mpi until mpi4py gets python3_8
-#IUSE="examples mpi"
-IUSE="examples"
-
-#RDEPEND="sci-libs/hdf5:=[mpi=,hl(+)]
-DEPEND="
- sci-libs/hdf5:=[hl(+)]
-"
-RDEPEND="
- ${DEPEND}
- >=dev-python/numpy-1.14.5[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.14.5[${PYTHON_USEDEP}]
- dev-python/pkgconfig[${PYTHON_USEDEP}]
- test? (
- dev-python/QtPy[testlib,${PYTHON_USEDEP}]
- )
-"
-# mpi? ( virtual/mpi )
-# mpi? ( dev-python/mpi4py[${PYTHON_USEDEP}] )
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs \
- dev-python/alabaster
-
-#pkg_setup() {
-# use mpi && export CC=mpicc
-#}
-
-python_prepare_all() {
- local PATCHES=(
- "${FILESDIR}"/${P}-types.patch
- )
-
- # avoid pytest-mpi dep, we do not use mpi anyway
- sed -i -e 's:pytest-mpi::' pytest.ini || die
- distutils-r1_python_prepare_all
-
- export H5PY_SETUP_REQUIRES=0
-}
-
-python_test() {
- cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
- epytest -m "not mpi"
-}
-
-python_install_all() {
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}