summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-29 07:54:26 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-29 08:17:00 +0200
commit305c4fedc01d4a219ad0dd8750aa6576c03a60f5 (patch)
treed7b90ecf5ea15fb89fc50c708a61f7c6b13fe0b4 /dev-python/hatchling/hatchling-0.24.0.ebuild
parentdev-python/pyspnego: Bump to 0.5.2 (diff)
downloadgentoo-305c4fedc01d4a219ad0dd8750aa6576c03a60f5.tar.gz
gentoo-305c4fedc01d4a219ad0dd8750aa6576c03a60f5.tar.bz2
gentoo-305c4fedc01d4a219ad0dd8750aa6576c03a60f5.zip
dev-python/hatchling: Bump to 0.24.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hatchling/hatchling-0.24.0.ebuild')
-rw-r--r--dev-python/hatchling/hatchling-0.24.0.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/hatchling/hatchling-0.24.0.ebuild b/dev-python/hatchling/hatchling-0.24.0.ebuild
new file mode 100644
index 000000000000..74fbe0e7a565
--- /dev/null
+++ b/dev-python/hatchling/hatchling-0.24.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+TAG=${P/-/-v}
+MY_P=hatch-${TAG}
+DESCRIPTION="Modern, extensible Python build backend"
+HOMEPAGE="
+ https://pypi.org/project/hatchling/
+ https://github.com/ofek/hatch/
+"
+SRC_URI="
+ https://github.com/ofek/hatch/archive/${TAG}.tar.gz
+ -> ${MY_P}.tar.gz
+"
+S=${WORKDIR}/${MY_P}/backend
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ia64 ~m68k ~ppc ~riscv ~s390 ~sparc"
+
+RDEPEND="
+ >=dev-python/editables-0.2[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.9[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.2.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/atomicwrites[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ dev-python/tomli-w[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ # TODO: remove this when gpep517 is the norm
+ local -x PYTHONPATH=src
+ distutils-r1_python_compile
+}
+
+python_test() {
+ local -x EPYTEST_DESELECT=(
+ # these run pip to install stuff
+ tests/backend/dep/test_core.py::test_dependency_found
+ tests/backend/dep/test_core.py::test_extra_met
+ tests/backend/dep/test_core.py::test_extra_no_dependencies
+ tests/backend/dep/test_core.py::test_extra_unmet
+ tests/backend/dep/test_core.py::test_unknown_extra
+ tests/backend/dep/test_core.py::test_version_unmet
+ )
+
+ # top-level "tests" directory contains tests both for hatch
+ # and hatchling
+ cd "${WORKDIR}/${MY_P}" || die
+ local -x PYTHONPATH="src:${PYTHONPATH}"
+ epytest tests/backend
+}