summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-08-15 17:27:23 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-08-15 17:28:31 +0000
commit66790ec514b9db27c6db71c4008595df2837acce (patch)
tree73bb4dc165a7d6cb37dc41180307cf8e6fe9fdd4 /dev-python/healpy/healpy-1.11.0.ebuild
parentdev-python/pytest-cython: initial import (diff)
downloadgentoo-66790ec514b9db27c6db71c4008595df2837acce.tar.gz
gentoo-66790ec514b9db27c6db71c4008595df2837acce.tar.bz2
gentoo-66790ec514b9db27c6db71c4008595df2837acce.zip
dev-python/healpy: version bump
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'dev-python/healpy/healpy-1.11.0.ebuild')
-rw-r--r--dev-python/healpy/healpy-1.11.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/healpy/healpy-1.11.0.ebuild b/dev-python/healpy/healpy-1.11.0.ebuild
new file mode 100644
index 000000000000..c517d95ea5cf
--- /dev/null
+++ b/dev-python/healpy/healpy-1.11.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for healpix"
+HOMEPAGE="https://github.com/healpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/astropy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-astronomy/healpix:=[cxx]
+ sci-libs/cfitsio:="
+DEPEND="${RDEPEND}
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cython[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( README.rst CHANGELOG.rst CITATION )
+
+python_test() {
+ echo "backend: Agg" > matplotlibrc || die
+ MPLCONFIGDIR=. esetup.py test || die
+ rm matplotlibrc || die
+}