summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-07-01 20:51:19 +0200
committerMatt Turner <mattst88@gentoo.org>2020-07-16 21:13:51 -0700
commit2805ae78f536b871bb830f5939f833208053d30c (patch)
tree77a0a6cb1cb510d96cd382005965e476dddae8d2 /dev-python/helpdev
parentdev-python/geventhttpclient: arm64 stable (bug #731394) (diff)
downloadgentoo-2805ae78f536b871bb830f5939f833208053d30c.tar.gz
gentoo-2805ae78f536b871bb830f5939f833208053d30c.tar.bz2
gentoo-2805ae78f536b871bb830f5939f833208053d30c.zip
dev-python/helpdev: version bump 0.7.1, add py3_8,9
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/16540 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-python/helpdev')
-rw-r--r--dev-python/helpdev/Manifest1
-rw-r--r--dev-python/helpdev/helpdev-0.7.1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/helpdev/Manifest b/dev-python/helpdev/Manifest
index 6cd8d947b85e..cf681794eb1a 100644
--- a/dev-python/helpdev/Manifest
+++ b/dev-python/helpdev/Manifest
@@ -1 +1,2 @@
DIST helpdev-0.6.10.tar.gz 12864 BLAKE2B f022e4a76b8f416e806bc11c11c27e4ee1c2a92cdc2a19561d2e8c0de60027eb03ae6696d968f7dcd803d2a9935c4ee9b3a0f8248f4cb8ca2afb13ff58d8be46 SHA512 6bdd51e573ec656de12e5b4c17e0de7c2cbfc26e696bb6f62eacd148fecde1c8c239879a9d44f8a30b12d744ab40e225799fe6176805d676cecabcbee6c1e4ff
+DIST helpdev-0.7.1.tar.gz 51575 BLAKE2B b780513c8b7af12296c003360c5805e8414e5c82fe459ab1e4ccaf68c9f029c817a6cb86535d26ad0143ea7dc60fb86126f6d87d4a84e85a9b29a9dbe651e2c8 SHA512 ba0af843617c7cc69aae2bfe88d437e90df14afa90dd0a76c0e7c1062f03963270514ff7653c859a70caec0cde3cc3f18ca87573fdb6a1d5e2fd5874cc24e59e
diff --git a/dev-python/helpdev/helpdev-0.7.1.ebuild b/dev-python/helpdev/helpdev-0.7.1.ebuild
new file mode 100644
index 000000000000..48dabc7184c9
--- /dev/null
+++ b/dev-python/helpdev/helpdev-0.7.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Helping users and developers to get information about the environment"
+HOMEPAGE="https://gitlab.com/dpizetta/helpdev"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' python3_{6,7,8} )
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest