summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-28 17:12:48 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-28 17:12:48 +0100
commit95ee7938371f1439ce6f059145e48de95bb4bc75 (patch)
treeb48bfbdd5d8ced0701cf91c252362f512c74d60f /dev-python/hiredis/hiredis-0.2.0-r1.ebuild
parentdev-python/hglib: Remove Py2 (diff)
downloadgentoo-95ee7938371f1439ce6f059145e48de95bb4bc75.tar.gz
gentoo-95ee7938371f1439ce6f059145e48de95bb4bc75.tar.bz2
gentoo-95ee7938371f1439ce6f059145e48de95bb4bc75.zip
dev-python/hiredis: Remove Py2
Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/hiredis/hiredis-0.2.0-r1.ebuild')
-rw-r--r--dev-python/hiredis/hiredis-0.2.0-r1.ebuild8
1 files changed, 1 insertions, 7 deletions
diff --git a/dev-python/hiredis/hiredis-0.2.0-r1.ebuild b/dev-python/hiredis/hiredis-0.2.0-r1.ebuild
index 1ac28728b1f2..98fe1101aaf6 100644
--- a/dev-python/hiredis/hiredis-0.2.0-r1.ebuild
+++ b/dev-python/hiredis/hiredis-0.2.0-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python3_{5,6} )
inherit distutils-r1
@@ -19,9 +19,3 @@ DEPEND=">=dev-libs/hiredis-0.13.1"
RDEPEND="${DEPEND}"
PATCHES=( "${FILESDIR}"/${P}-r1-system-libs.patch )
-
-python_compile() {
- python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
-
- distutils-r1_python_compile
-}