summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-31 09:11:54 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-31 09:26:16 +0200
commite0adb04717cbdb182b794a7902e512482aaf634a (patch)
treea33b2e6e5962fe23d36e00e37132168a8804fd9b /dev-python/hpack
parentdev-perl/File-RsyncP: -r bump for EAPI7 + Fixes (diff)
downloadgentoo-e0adb04717cbdb182b794a7902e512482aaf634a.tar.gz
gentoo-e0adb04717cbdb182b794a7902e512482aaf634a.tar.bz2
gentoo-e0adb04717cbdb182b794a7902e512482aaf634a.zip
dev-python/hpack: Bump to 4.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hpack')
-rw-r--r--dev-python/hpack/Manifest1
-rw-r--r--dev-python/hpack/hpack-4.0.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/hpack/Manifest b/dev-python/hpack/Manifest
index 9c95e6ee7928..5a78d6f92ee8 100644
--- a/dev-python/hpack/Manifest
+++ b/dev-python/hpack/Manifest
@@ -1 +1,2 @@
DIST hpack-3.0.0.tar.gz 5305971 BLAKE2B d1df8a1b2a1ce8b91e63cab475d3957f937fb74c0bec343d342971be1bb7cfbc929c53cf041845df2965cef0cfb098345bf0612acabc7ef3e5e23f6f0aa44f2f SHA512 7b9cf5e643dff2a6454bfe419b797c8ed1a0fe6ec3b725d2696da5a820ab96fe87a64e600b1831c7024bd82616b155a0aa058301acb32172155b6538ba0a73c6
+DIST hpack-4.0.0.tar.gz 5301419 BLAKE2B 0164f6aafc0d1f17f6c397efe710503a22501faae3c7dbba4e57ca2dc76e4d373bc5e65bf55acda8bc61975d12f8a2084de0e0c4587539e5a3102e3cf66d562b SHA512 f482d086d7a82649393e3cfea55c98966ce57055cb1826bc4dec1ea334661c02708e7903f2e8e588ee1c30df41373e1de9fb960c2e7bbc18d0ace0b8f97b195b
diff --git a/dev-python/hpack/hpack-4.0.0.ebuild b/dev-python/hpack/hpack-4.0.0.ebuild
new file mode 100644
index 000000000000..3d2885a39310
--- /dev/null
+++ b/dev-python/hpack/hpack-4.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python HPACK header compression"
+HOMEPAGE="
+ https://python-hyper.org/hpack/en/latest/
+ https://pypi.org/project/hpack/"
+SRC_URI="https://github.com/python-hyper/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+# dev-python/pytest-relaxed causes tests to fail
+BDEPEND="
+ test? (
+ >=dev-python/hypothesis-3.4.2[${PYTHON_USEDEP}]
+ !!dev-python/pytest-relaxed[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest