summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/html2text/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/html2text/files')
-rw-r--r--dev-python/html2text/files/html2text-noinstall-test.patch35
-rw-r--r--dev-python/html2text/files/html2text-rename.patch15
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/html2text/files/html2text-noinstall-test.patch b/dev-python/html2text/files/html2text-noinstall-test.patch
new file mode 100644
index 000000000000..70068a847234
--- /dev/null
+++ b/dev-python/html2text/files/html2text-noinstall-test.patch
@@ -0,0 +1,35 @@
+From e4d46b478f78c4464c7b35058154948c928a013b Mon Sep 17 00:00:00 2001
+From: Arfrever <arfrever@github.com>
+Date: Thu, 29 May 2014 18:07:21 +0200
+Subject: [PATCH] Don't install tests (but include them in PyPI package).
+
+Fixes #9
+---
+ MANIFEST.in | 1 +
+ setup.py | 1 -
+ 2 files changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/MANIFEST.in b/MANIFEST.in
+index 1845310..6217360 100644
+--- a/MANIFEST.in
++++ b/MANIFEST.in
+@@ -2,3 +2,4 @@ include COPYING
+ include README.md
+ include ChangeLog.rst
+ include AUTHORS.rst
++recursive-include test *.html *.md *.py
+diff --git a/setup.py b/setup.py
+index 3b7085d..0b2cf08 100644
+--- a/setup.py
++++ b/setup.py
+@@ -65,7 +65,6 @@ def run(self):
+ """,
+ license='GNU GPL 3',
+ requires=requires_list,
+- packages=find_packages(),
+ py_modules=['html2text'],
+ include_package_data=True,
+ zip_safe=False,
+--
+1.9.3
+
diff --git a/dev-python/html2text/files/html2text-rename.patch b/dev-python/html2text/files/html2text-rename.patch
new file mode 100644
index 000000000000..5857ef4957b9
--- /dev/null
+++ b/dev-python/html2text/files/html2text-rename.patch
@@ -0,0 +1,15 @@
+Naming conflict with app-text/html2text, bug 421647.
+
+diff --git a/setup.py b/setup.py
+index dd3d9bc..cd28b49 100644
+--- a/setup.py
++++ b/setup.py
+@@ -26,7 +26,7 @@ setup(
+ ],
+ entry_points="""
+ [console_scripts]
+- html2text=html2text:main
++ pyhtml2text=html2text:main
+ """,
+ license='GNU GPL 3',
+ packages=find_packages(),