summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2018-02-10 21:25:34 -0800
committerZac Medico <zmedico@gentoo.org>2018-02-10 21:34:18 -0800
commit34187094625c5c45e338ca19e551a05aeaf993fe (patch)
tree3dc35a4040b9967b21aba7bfc42491c191548c19 /dev-python/html5-parser/html5-parser-0.4.4-r1.ebuild
parentmedia-plugins/kodi-inputstream-adaptive: 2.0.10 version bump (diff)
downloadgentoo-34187094625c5c45e338ca19e551a05aeaf993fe.tar.gz
gentoo-34187094625c5c45e338ca19e551a05aeaf993fe.tar.bz2
gentoo-34187094625c5c45e338ca19e551a05aeaf993fe.zip
dev-python/html5-parser: disable soup test
Closes: https://bugs.gentoo.org/647066 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-python/html5-parser/html5-parser-0.4.4-r1.ebuild')
-rw-r--r--dev-python/html5-parser/html5-parser-0.4.4-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/html5-parser/html5-parser-0.4.4-r1.ebuild b/dev-python/html5-parser/html5-parser-0.4.4-r1.ebuild
new file mode 100644
index 000000000000..096a8db46e0c
--- /dev/null
+++ b/dev-python/html5-parser/html5-parser-0.4.4-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fast C based HTML 5 parsing for python"
+HOMEPAGE="https://github.com/kovidgoyal/html5-parser/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/libxml2:=
+ dev-python/chardet[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.8.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ # Soup is not used when lxml is available.
+ rm test/soup.py || die
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}