summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-05 15:48:07 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-05 15:51:48 +0200
commitc9722006214d5a66a7f8504aa3cdf3551d8bcc44 (patch)
treec68b36433c86c9c7d58814448569367b46ee31ee /dev-python/html5-parser/html5-parser-0.4.9.ebuild
parentdev-python/httmock: Enable py3.10 (diff)
downloadgentoo-c9722006214d5a66a7f8504aa3cdf3551d8bcc44.tar.gz
gentoo-c9722006214d5a66a7f8504aa3cdf3551d8bcc44.tar.bz2
gentoo-c9722006214d5a66a7f8504aa3cdf3551d8bcc44.zip
dev-python/html5-parser: Enable py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/html5-parser/html5-parser-0.4.9.ebuild')
-rw-r--r--dev-python/html5-parser/html5-parser-0.4.9.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/html5-parser/html5-parser-0.4.9.ebuild b/dev-python/html5-parser/html5-parser-0.4.9.ebuild
index 570a72670df2..8e4ed1d92edd 100644
--- a/dev-python/html5-parser/html5-parser-0.4.9.ebuild
+++ b/dev-python/html5-parser/html5-parser-0.4.9.ebuild
@@ -2,13 +2,13 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1 toolchain-funcs
DESCRIPTION="Fast C based HTML 5 parsing for python"
HOMEPAGE="https://github.com/kovidgoyal/html5-parser/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
@@ -35,5 +35,5 @@ src_configure() {
}
python_test() {
- esetup.py test || die "Tests failed under ${EPYTHON}"
+ esetup.py test
}